Bug 173824 - php-pear pop3 implementation doesn't seem to work - hangs indefinitely when called
php-pear pop3 implementation doesn't seem to work - hangs indefinitely when c...
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-11-21 12:54 EST by Morten Jensen
Modified: 2008-03-09 16:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-09 16:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Morten Jensen 2005-11-21 12:54:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
I'm using tikiwiki (tikiwiki.org) and after I upgraded to the php-pear-5.0.4-10.5 package, the PHP POP3 implementation doesn't seem to be able to login to .

In version 1.9.2 of tikiwiki (tiki-webmail.php) the problem lies with the line:

if (!$pop3->connect($current["pop"]) || !$pop3->login($current["username"], $current["pass"])) {

I've tried to break the line into multiple lines and tested where things go wrong and it turns out that the pop3->login call never returns - it just hangs indefinitely for all pop3 servers (I've tested with quite a few).

I've also tried to add false and true as a third parameter to the call to check whether APOP is giving the problem - this made no difference either way, login was still hanging.

This worked fine in the previous release.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Use tikiwiki
2.call up the page tiki-webmail.php to view email from a pop3 account
3. The page will hang indefinitely

Actual Results:  The web server never responds - the pop3->login call never returns.

Expected Results:  I'm able to see my webmail through e.g. tikiwiki

Additional info:
Comment 1 Marius Andreiana 2005-11-21 13:50:46 EST
Have you tested with the upstream version of this package? If that doesn't work,
please report it there.
Comment 2 Morten Jensen 2005-11-21 15:02:44 EST

This may be a stupid question but what's an upstream package version?

Also, used setDebug to enable debugging and found after a few minutes that
Net_POP3 returned:

S:+OK mail.toftgaard.name POP3 server (JAMES POP3 Server 2.1.3) ready C: CAPA
S:-ERR S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S: S:
S: S: S: S: S: S: S:

As you can see something seems to go wrong when CAPA is sent.

Comment 3 Marius Andreiana 2005-11-22 00:56:29 EST
In a different location than /usr/share/pear, install the original pear package
then download and install the original (upstream) net_pop3

You could try first to simply overwrite (after making a backup) files from
/usr/share/pear/ with the files from http://pear.php.net/get/Net_POP3-1.3.6.tgz
Comment 4 Christian Iseli 2007-01-22 06:54:16 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 5 petrosyan 2008-03-09 16:53:36 EDT
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.