Bug 173833 - automount segfaults
automount segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 14:15 EST by Bill Nottingham
Modified: 2014-03-16 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.1.4-16.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 13:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-11-21 14:15:16 EST
automount[5269]: segfault at 000000005566a898 rip 00002aaaab05330f rsp
00007fffff980a50 error 4
automount[5314]: segfault at 000000005566a898 rip 00002aaaab05330f rsp
00007fffffc7da70 error 4
automount[5363]: segfault at 000000005566a898 rip 00002aaaab05330f rsp
00007fffff82b160 error 4
[root@apone log]# rpm -q autofs
autofs-4.1.4-14

[root@apone log]# cat /etc/auto.master
/mnt
ldap:devserv.devel.redhat.com:nisMapName=auto.mnt,dc=devel,dc=redhat,dc=com/misc
ldap:devserv.devel.redhat.com:nisMapName=auto.misc,dc=devel,dc=redhat,dc=com
--timeout=60
/home
ldap:devserv.devel.redhat.com:nisMapName=auto.home,dc=devel,dc=redhat,dc=com
--timeout=60
Comment 1 Jeff Moyer 2005-11-21 14:19:30 EST
Please include more information in your bug report.  Refer to the section
entitled "Filing bug reports" on the following web page:
  http://people.redhat.com/jmoyer/

Thanks.
Comment 2 Bill Nottingham 2005-11-21 14:22:18 EST
kernel-2.6.14-1.1696_FC5

No current automount status, as it dies on startup (although it reports success)

Will test some more momentarily.
Comment 3 Bill Nottingham 2005-11-21 15:00:32 EST
Debug messages are:

Nov 21 15:08:35 apone automount[3451]: starting automounter version 4.1.4-14,
path = /mnt, maptype = ldap, mapname =
devserv.devel.redhat.com:nisMapName=auto.mnt,dc=devel,dc=redhat,dc=com
Nov 21 15:08:35 apone automount[3451]: lookup(ldap): server =
"devserv.devel.redhat.com", port = 389, base dn =
"nisMapName=auto.mnt,dc=devel,dc=redhat,dc=com"
Nov 21 15:08:35 apone automount[3495]: starting automounter version 4.1.4-14,
path = /misc, maptype = ldap, mapname =
devserv.devel.redhat.com:nisMapName=auto.misc,dc=devel,dc=redhat,dc=com
Nov 21 15:08:35 apone automount[3495]: lookup(ldap): server =
"devserv.devel.redhat.com", port = 389, base dn =
"nisMapName=auto.misc,dc=devel,dc=redhat,dc=com"Nov 21 15:08:35 apone
automount[3544]: starting automounter version 4.1.4-14, path = /home, maptype =
ldap, mapname =
devserv.devel.redhat.com:nisMapName=auto.home,dc=devel,dc=redhat,dc=com
Nov 21 15:08:35 apone automount[3544]: lookup(ldap): server =
"devserv.devel.redhat.com", port = 389, base dn =
"nisMapName=auto.home,dc=devel,dc=redhat,dc=com"
Comment 4 Bill Nottingham 2005-11-21 15:08:05 EST
Program received signal SIGSEGV, Segmentation fault.
[Switching to process 3816]
0x00002aaaab05330f in ldap_set_option () from /usr/lib64/libldap-2.3.so.0
(gdb) bt
#0  0x00002aaaab05330f in ldap_set_option () from /usr/lib64/libldap-2.3.so.0
#1  0x00002aaaaaf08558 in ?? () from /usr/lib64/autofs/lookup_ldap.so
#2  0x00002aaaaaf08820 in lookup_init () from /usr/lib64/autofs/lookup_ldap.so
#3  0x000055555555b629 in open_lookup () from /usr/sbin/automount
#4  0x000055555555aa13 in main () from /usr/sbin/automount
(gdb)
Comment 5 Bill Nottingham 2005-11-21 15:09:49 EST
With debuginfo:

Program received signal SIGSEGV, Segmentation fault.
[Switching to process 3847]
ldap_set_option (ld=0x5566b1d0, option=17, invalue=0x7ffffffafee4)
    at ../../../libraries/libldap/options.c:358
358                     assert( LDAP_VALID( ld ) );
(gdb) bt
#0  ldap_set_option (ld=0x5566b1d0, option=17, invalue=0x7ffffffafee4)
    at ../../../libraries/libldap/options.c:358
#1  0x00002aaaaaf08558 in do_connect () from /usr/lib64/autofs/lookup_ldap.so
#2  0x00002aaaaaf08820 in lookup_init () from /usr/lib64/autofs/lookup_ldap.so
#3  0x000055555555b629 in open_lookup () from /usr/sbin/automount
#4  0x000055555555aa13 in main () from /usr/sbin/automount
Comment 6 Jeff Moyer 2005-11-21 16:22:08 EST
After speaking with hack, it seems that ldap_simple_bind_s is now deprecated. 
We can go one of two ways with this.  We either define LDAP_DEPRECATED in the
automounter sources, or we fix it to use ldap_sasl_bind_s.  For test1, I say we
simply define LDAP_DEPRECATED.  Then, I'll work on a proper fix for the longer term.
Comment 7 Bill Nottingham 2006-01-23 17:53:28 EST
Any progress on this - AFAIK it's still broken in the same way.
Comment 8 Jeff Moyer 2006-01-24 07:09:24 EST
Strange, I thought I fixed this.  It simply needs -DUSE_DEPRECATED or some such
in the build line (or to be ported to the new interfaces).

I'll see about getting this fix in, thanks for the prodding.
Comment 9 Ian Kent 2006-01-25 01:01:30 EST
(In reply to comment #8)
> Strange, I thought I fixed this.  It simply needs -DUSE_DEPRECATED or some such
> in the build line (or to be ported to the new interfaces).
> 
> I'll see about getting this fix in, thanks for the prodding.

The patch you sent over looked straight forward so, after a basic test on 32 bit
arch I've gone ahead and applied and built it into devel.

Bill, could you arrange to test on 64 bit arch plase and see if it acutally does
anything!
Comment 10 Bill Nottingham 2006-01-25 10:03:48 EST
Will test when I'm back in the RDU office.
Comment 11 Bill Nottingham 2006-01-30 13:06:57 EST
Yup, works for me now.

Note You need to log in before you can comment on or make changes to this bug.