Bug 173844 - CDROM test shows failures when doing cdrom and dvd tests together
CDROM test shows failures when doing cdrom and dvd tests together
Status: CLOSED ERRATA
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: cdrom (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Will Woods
Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 15:46 EST by Jeff Lane
Modified: 2007-04-18 13:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-871
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 10:37:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /usr/share/rhr/tests/CDROM (193 bytes, patch)
2005-11-21 15:47 EST, Jeff Lane
no flags Details | Diff
patch to /usr/share/rhr/tests/cdrom/functions (642 bytes, patch)
2005-11-21 15:47 EST, Jeff Lane
no flags Details | Diff

  None (edit)
Description Jeff Lane 2005-11-21 15:46:59 EST
Description of problem:
Found that when running the CDROM test against a combo drive (cdrom,dvd) package
failures are noted when the DVD portion runs the md5sum check.

The reason for this is:  
given this hardware.conf entry: CDROM sda(cdrom,dvd)
the test executes like this:
1.  create /tmp/rhr/CDROM/device and /tmp/rhr/CDROM/tmp
2.  mount CDROM device (w/ CD media) to ./device
3.  cp -av ./device/RedHat/RPMS/* ./tmp
4.  do md5sum on ./tmp/* and compare (using md5sum -c) to ./device/RedHat/RPMS/*
5.  umount cdrom and ask user to swap in a dvd
6.  mount dvd to ./device
7.  cp -av ./device/RedHat/RPMS/* ./tmp
8.  same as step 4 above
9.  umount ./device
10.  rm -f ./device ./tmp

The problem falls between the cdrom reader and dvd reader tests.  Since the
files in ./tmp are not cleaned up prior to the dvd reader test, the files from
the cd reader test are still present, and if they are not overwritten when the
dvd reader test copies files to ./tmp, the md5sum check will result in failures.

I have attached patch files with changes to /usr/share/rhr/tests/CDROM and
/usr/share/rhr/tests/cdrom/functions that fix this.  Probably not the more
elegant or even permenant solution, but they DO fix the issue.

Version-Release number of selected component (if applicable):
rhr2-1.1-3

How reproducible:
always...

Steps to Reproduce:
1.see above.  especially visible if you use a RHEL4 x86 cdrom and a RHEL4 U2
x86_64 dvd or some other similar mix.
2.
3.
  
Actual results:
The RHR suite says PASSED, but the logs show failed pacakge checksums during dvd
reader portion

Expected results:
Temp directories should be cleaned up between passes to prevent this kind of
thing from happening.  Also, the summary should not say PASS if words like
FAILED and WARNING are present in the log file.

Additional info:see attached patches.
Comment 1 Jeff Lane 2005-11-21 15:47:00 EST
Created attachment 121315 [details]
patch to /usr/share/rhr/tests/CDROM
Comment 2 Jeff Lane 2005-11-21 15:47:57 EST
Created attachment 121316 [details]
patch to /usr/share/rhr/tests/cdrom/functions
Comment 3 Will Woods 2005-12-08 13:50:23 EST
Recent changes to the CDROM test should fix this problem.
Comment 4 Red Hat Bugzilla 2005-12-20 10:37:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-871.html

Note You need to log in before you can comment on or make changes to this bug.