Bug 173845 - Exception from deselecting packages
Exception from deselecting packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 174446 174517 174769 177440 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 15:52 EST by James Morris
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 10:51:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file (244.06 KB, text/plain)
2005-11-21 15:55 EST, James Morris
no flags Details

  None (edit)
Description James Morris 2005-11-21 15:52:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
I get a repeatable anaconda exception installing from FC-5-Test1-20051120.1-i386-disc2-ftp.iso

Happens after disk partition and after the install image is written to disk.

I selected no package groups (also happened with I think the editors group and system tools).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install OS from CD
2.
3.
  

Actual Results:  Anaconda exception

Expected Results:  The joy of Linux

Additional info:

I'll attach an anaconda dump file
Comment 1 James Morris 2005-11-21 15:53:46 EST
Should be disc1, obviously.
Comment 2 James Morris 2005-11-21 15:55:03 EST
Created attachment 121317 [details]
Anaconda dump file
Comment 3 Jeremy Katz 2005-11-21 16:13:05 EST
Stop trying to deselect things ;) 

More seriously, yeah, the package selection code is verrryy fragile for
deselecting things at present.
Comment 4 James Morris 2005-11-21 19:27:23 EST
Ok, seems to work ok now if I don't deselect anything.
Comment 5 Ville Skyttä 2005-11-27 08:43:19 EST
Wouldn't this be something that should be noted in
http://fedoraproject.org/wiki/FC5Test1CommonProblems ?

(The wiki page says it'll crash if all packages are unselected, but in my case
it crashed like described in the initial comment here as a result of deselecting
only the printing group and leaving everything else at defaults.)
Comment 6 Chris Lumens 2005-11-29 10:12:28 EST
The wiki page has been updated to reflect this.
Comment 7 Jeremy Katz 2005-11-30 22:30:32 EST
*** Bug 174517 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2005-11-30 22:37:46 EST
*** Bug 174446 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2005-12-01 21:51:20 EST
*** Bug 174769 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2006-01-17 15:51:04 EST
*** Bug 177440 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2006-01-18 10:51:39 EST
This was fixed after test1.

Note You need to log in before you can comment on or make changes to this bug.