Bug 173877 - vi-style scrolling absent
vi-style scrolling absent
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 21:11 EST by David A. De Graaf
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 22:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 83441 None None None Never

  None (edit)
Description David A. De Graaf 2005-11-21 21:11:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
For those of us with hands glued to the standard typing position,
the inability of firefox to scroll vi-style is a constant irritation.
The necessity to lift the hand over to the unnatural arrow keys, or god
forbid, the mouse, is just burdensome.  Why can't firefox obey the 
standard convention?  - move down with the right index finger,
up with the middle finger, left by reaching left, and right with the
third finger?  Scroll up a full page by reaching up to u, and down
with the thumb.

It turns out to be fairly simple to teach firefox to do this, moreover
without affecting its other "normal" behaviour, so the question remains -
why isn't this done standardly?  I don't know that answer.

It is merely necessary to add these definitions to the file,
platformHTMLBindings.xml

       <handler event="keypress" key="h" command="cmd_scrollLeft"/>
       <handler event="keypress" key="j" command="cmd_scrollLineDown"/>
       <handler event="keypress" key="k" command="cmd_scrollLineUp"/>
       <handler event="keypress" key="l" command="cmd_scrollRight"/>
       <handler event="keypress" key="u" command="cmd_scrollPageUp" />

However, this file is well concealed in
/usr/lib/firefox-1.0.7/chrome/toolkit.jar which is a zipped bunch of
files.  This must be unzipped, the file edited, and the package
rezipped.  

Please add these lines, officially, so this local modification isn't necessary.

Version-Release number of selected component (if applicable):
firefox-1.0.7-1.1.fc4

How reproducible:
Always

Steps to Reproduce:
1.  In firefox, try to scroll, using the keyboard.
2.
3.
  

Actual Results:  No scrolling.

Expected Results:  I would prefer firefox to obey normal conventions.

Additional info:
Comment 1 Nalin Dahyabhai 2005-11-23 14:01:37 EST
Duplicate of #173698?
Comment 2 David A. De Graaf 2006-05-12 13:47:07 EDT
Firefox's scrolling has gottem much worse in Fedora Core 5.  There's been no
response to my suggestion - I can live with that - I simply edit the bindings 
myself.  But the edits suggested above now don't work any more, as they used to.
 In the platformHTMLBindings.xml file, the commands cmd_scrollLineDown and
cmd_scrollLineDown no longer scroll the window contents.
Instead they move an invisible cursor down or up by one line, so that after many
keypresses to reach an extremity the text begins to move.  These commands have
forgotten the meaning of "scroll".

The same problem occurs with the up and down arrow keys - they don't scroll
either (because they are bound to the same defective commands). 

Something is seriously hosed.
Comment 3 David A. De Graaf 2006-05-13 11:27:10 EDT
I've just done yum update and firefox is now 
  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060504
Fedora/1.5.0.3-1.1.fc5 Firefox/1.5.0.3 pango-text

I'm sad to observe that it is still braindead WRT scrolling.  The up and down
arrows don't scroll, but move an invisible cursor.  There's no way to actually
scroll, except with the mouse roller wheel, and that's just too uncomfortable
for extended use.
Comment 4 Christopher Aillon 2006-10-30 22:08:41 EST
Hi, sorry for the delay in responding.  This was reported upstream at
https://bugzilla.mozilla.org/show_bug.cgi?id=83441 and resolved WONTFIX a long
while ago.  I don't want to deviate from upstream, so going to close this
WONTFIX, too.

Feel free to push this upstream, though, if you feel strongly about it.

Note You need to log in before you can comment on or make changes to this bug.