Bug 173879 - mesa-libGLw-devel: Missing headers
Summary: mesa-libGLw-devel: Missing headers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 173883
TreeView+ depends on / blocked
 
Reported: 2005-11-22 02:18 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 08:34:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (695 bytes, patch)
2005-12-05 15:24 UTC, Ralf Corsepius
no flags Details | Diff

Description Ralf Corsepius 2005-11-22 02:18:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
mesa-libGLw-devel-6.4-5.i386.rpm lacks all its headers nor are these provided by any other package in "modular X":

Missing are:
/usr/include/GL/GLwDrawA.h   /usr/include/GL/GLwMDrawA.h
/usr/include/GL/GLwDrawAP.h  /usr/include/GL/GLwMDrawAP.h


Version-Release number of selected component (if applicable):
mesa-libGLw-devel-6.4-5

How reproducible:
Always

Steps to Reproduce:
Compile a GLw based application.


Actual Results:  The current package/packaging is unusable and renders all GLw-based packages non-buildable.

Expected Results:  Function.


Additional info:

This bug prevents me from building SGI Inventor for FE.

Comment 1 Ralf Corsepius 2005-11-30 06:06:49 UTC
Ping? I didn't file this PR as "high priority" for fun!

Comment 2 Ralf Corsepius 2005-12-05 15:24:39 UTC
Created attachment 121854 [details]
Proposed patch

The patch is untested, because the mesa package currently doesn't build in a
FC5 chroot.

Comment 3 Mike A. Harris 2005-12-21 11:36:03 UTC
This appears to be a bug in the mesa project's build/install, rather than
a Fedora specific issue.  Please report the issue directly to the mesa
project via the freedesktop.org bugzilla.  We can include a workaround
for the short term, but it should get reported and fixed upstream.

Thanks in advance.

Setting status to NEEDINFO_REPORTER and awaiting upstream bug URL.

Comment 4 Ralf Corsepius 2005-12-21 16:00:55 UTC
(In reply to comment #3)
> This appears to be a bug in the mesa project's build/install, rather than
> a Fedora specific issue. 
Yes, the cause of this bug is in bin/mesainstall. It doesn't consider glw at all.
However the real cause is lurking much deeper: mesa's configury is badly designed.

> We can include a workaround for the short term,
Please do so. The mesa-libGLw-devel package in rawhide is plain "unusable" and
breaks existing packages. I had to pollute my packages with ugly hacks to work
around this defect of the mesa-libGLw* rpms.

> but it should get reported and fixed upstream.
https://bugs.freedesktop.org/show_bug.cgi?id=5396

Comment 5 Mike A. Harris 2005-12-24 08:34:50 UTC
Fixed in 6.4.1-3


Note You need to log in before you can comment on or make changes to this bug.