Bug 173885 - /usr/lib/rpm/rpmq: free(): invalid pointer: 0x096932b0
Summary: /usr/lib/rpm/rpmq: free(): invalid pointer: 0x096932b0
Status: CLOSED DUPLICATE of bug 162037
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 174861 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-22 04:10 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 22:14:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error output (6.83 KB, text/plain)
2005-11-22 04:10 UTC, Ricky Ng-Adam
no flags Details
what I got as an output (25.64 KB, text/plain)
2005-11-22 04:11 UTC, Ricky Ng-Adam
no flags Details
Command and backtrace from rpm -V (11.94 KB, text/plain)
2005-11-22 19:27 UTC, Andy Green
no flags Details

Description Ricky Ng-Adam 2005-11-22 04:10:53 UTC
Description of problem:

*** glibc detected *** /usr/lib/rpm/rpmq: free(): invalid pointer: 0x096932b0 ***

Version-Release number of selected component (if applicable):

rpm-4.4.1-22

How reproducible:

always

Steps to Reproduce:
1. execute `rpm -qaV > verified-list`
2. 
3.
  
Actual results:

crash

Expected results:

no crash

Additional info:

will attach complete backtrace and output file

Comment 1 Ricky Ng-Adam 2005-11-22 04:10:53 UTC
Created attachment 121329 [details]
error output

Comment 2 Ricky Ng-Adam 2005-11-22 04:11:49 UTC
Created attachment 121330 [details]
what I got as an output

Comment 3 Andy Green 2005-11-22 19:27:24 UTC
Created attachment 121366 [details]
Command and backtrace from rpm -V

Using rpm -V on filesystem package (only, it appears) causes the chunks to blow

Backtrace attached.

Comment 4 Paul Nasrat 2005-11-22 21:01:58 UTC
When FC5Test1 comes out can you upgrade rpm only on your system and see if it is
resolved.

Comment 5 Paul Nasrat 2005-12-02 22:10:35 UTC
*** Bug 174861 has been marked as a duplicate of this bug. ***

Comment 6 Paul Nasrat 2006-03-29 22:14:59 UTC

*** This bug has been marked as a duplicate of 162037 ***


Note You need to log in before you can comment on or make changes to this bug.