Bug 173896 - Please Requires libvisual-plugins
Please Requires libvisual-plugins
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-11-22 05:54 EST by Michael A. Peters
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-21 09:25:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2005-11-22 05:54:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Please explicit Requires libvisual-plugins in amarok-visualisation subpackage

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install amarok-visualisation

Actual Results:  notice that libvisual plugins are not available from visualisation menu

Expected Results:  It is should (imho) pull in the plugins

Additional info:
Comment 1 Aurelien Bompard 2005-11-22 07:12:55 EST
Amarok without libvisual-plugins can use visualisation plugins from xmms. Xmms
is automatically installed by amarok-visualisation because of the dependency on
libxmms.so.1, so amarok-visualisation ships with plugins out-of-the-box.
I tend to think that plugins should never be Require'd in spec file if we want
them to remain what they are -- plugins, that can be added or not.
What do you think ?
Comment 2 Michael A. Peters 2005-11-22 15:37:15 EST
Granted, they are plugins - but if a user installs the amarok-visualisation
package, then visualizers is what the user is after.

It's up to you, I consider it an RFE and not a functionality bug - since it is
not difficult for the user to figure out what they need.
Comment 3 Aurelien Bompard 2006-05-21 09:25:06 EDT
"Suggest" (aka Requires(hint)) is in RPM CVS, I've added a comment into
amarok-visualisation with "Requires(hint): libvisual-plugins". I'll enable it
when it's available in FC.

Note You need to log in before you can comment on or make changes to this bug.