Bug 173898 - package dependency is broken
package dependency is broken
Status: CLOSED NOTABUG
Product: Fedora Infrastructure
Classification: Retired
Component: other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 07:05 EST by Éric Brunet
Modified: 2007-04-18 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-22 10:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Éric Brunet 2005-11-22 07:05:39 EST
Today, I issued yum update. yum proposed to update SDL_mixer, from
fedora-extras, (85 kB) and, to resolve dependancy, to install timidity++ (9 MB)

This is insane. I can understand the logic, but I am ready to accept that SDL
application won't be able to play midi files if timidity is not installed. Maybe
timidity should be suggested, but it should not be a hard dependancy forcing me
to install this chunk of 9MB if I just need SDL_mixer for an application playing
bitmap sounds !

This is just one example that stroke me today. Other examples include:

kdepim needs pilot-link. (I will never own a pilot, and most applications in
kdepim work without pilot-link. Why should I install it for the one program that
needs it and that I will never use ?)

kdegraphics needs sane-backends. I don't own a scanner.

tetex-xdvi needs fonts-japanese. I promise I will never typeset japanese
document, nor try to read one, but I need 40 MB of japanese fonts !!!

Etc. There are many similar examples.

There needs to be some compromise between functionality and place on the hard
drive. I believe that, in an ideal world, those package would not get
automatically installed. If a user tries to watch a dvi files with japanese
fonts, it should fail till the fonts are installed, because that is what is
needed by most of the users. kde applications should not be linked to pilot-link
libraries, but should dlopen them if needed. That way, thay could be started
without the libraries present. And if the world were really ideal, a nice popup
explaining that I need to install this and this package for the functionnality I
asked for would appear when needed.

That is, of course, a major task, but really, the current situation is a very
fast way to bloat. It doesn't scale and is fundamentally broken.

Thank you for your attention.
Comment 1 Warren Togami 2005-11-22 10:36:57 EST
Fedora is designed this way.  RPM dependencies and the way we use them are to
ensure reproducibility, which we believe is one important aspect of stability. 
Most of our users are accepting of this.  However in some cases we do explicitly
remove dependencies if they are seemingly unnecessary.  If you have specific
complaints about a certain package, then please file bugs against that package.

If you want to change the fundamental way that rpm works, then Bugzilla is an
inappropriate medium for such discussion.  However there have been hundreds of
such discussions in the past and all of have been rejected.  You personally may
be happier running a different distribution like Debian which has a different
design philosophy.  

Note You need to log in before you can comment on or make changes to this bug.