Bug 173909 - visiting URL causes privoxy to endlessly loop, burning all CPU
visiting URL causes privoxy to endlessly loop, burning all CPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: privoxy (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 10:02 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 08:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2005-11-22 10:02:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Visiting the following URL seems to cause privoxy to loop, eating a CPU cycles.

http://news.google.com/url?sa=t&ct=us/4-2-0&fp=4383d961946e9ac1&ei=cDGDQ8-aJrKk6AH78uHbBg&url=http%3A//www.techworld.com/applications/news/index.cfm%3FNewsID%3D4838&cid=1102516272

'service privoxy restart' kills and restarts it, but revisting the above link reproduces behavior.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Firefox, visit 'news.google.com', click on 'Micro opens Office file formats'
2. browser hangs, privoxy eating all cpu
3.
  

Additional info:
Comment 2 Tom London 2005-12-19 10:10:00 EST
Here's another URL that seems to cause problems for me:
http://weather.yahoo.com/forecast/USCA0746_f.html

I find many of these in /var/log/privoxy/logfile:

Dec 19 07:09:57 Privoxy(-1250301008) Request:
weather.yahoo.com/forecast/USCA0273.html
Dec 19 07:09:57 Privoxy(-1229321296) Error: write modified content to client
failed: Operation now in progress
Dec 19 07:10:00 Privoxy(-1229321296) Request:
weather.yahoo.com/forecast/USCA0693.html
Dec 19 07:10:00 Privoxy(-1250301008) Error: write modified content to client
failed: Operation now in progress
Dec 19 07:10:02 Privoxy(-1250301008) Request:
weather.yahoo.com/imgindex/uscities.html
Dec 19 07:10:02 Privoxy(-1229321296) Error: write modified content to client
failed: Operation now in progress
Dec 19 07:10:04 Privoxy(-1250301008) Request: weather.yahoo.com/imgindex/world.html
Dec 19 07:10:06 Privoxy(-1250301008) Error: write modified content to client
failed: Operation now in progress
Dec 19 07:10:06 Privoxy(-1229321296) Request:
weather.yahoo.com/storm_center/index.html
Dec 19 07:10:07 Privoxy(-1250301008) Request:
weather.yahoo.com/climo/USCA0746_f.html
Dec 19 07:10:07 Privoxy(-1250301008) Request:
weather.yahoo.com/climo/USCA0746_f.htmlOperation now in progress
Comment 3 Tom London 2005-12-19 18:27:14 EST
This occurs on a Windows box running 3.0.3 as well.

This appears to be an upstream problem:
http://sourceforge.net/tracker/index.php?func=detail&aid=1347670&group_id=11118&atid=111118
Comment 4 Karsten Hopp 2007-01-02 08:39:12 EST
Seems to be fixed in privoxy-3.0.6, at least I can't reproduce it anymore.
Please reopen if it happens again with 3.0.6

Note You need to log in before you can comment on or make changes to this bug.