Bug 173911 - Random crash on Qcad during zooming
Random crash on Qcad during zooming
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qcad (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
---
:
: 173900 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 10:17 EST by antonio montagnani
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-25 16:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
small lay-out in dxf format (15.10 KB, image/vnd.dxf)
2005-11-23 05:56 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2005-11-22 10:17:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Sometimes Qcad crashes (application closes), especially when zooming in or out, but also when resizing grid, if I wanat a smaller grid for example.
Sometimes it happens also during copy elements

Version-Release number of selected component (if applicable):
qcad-2.04.0-5fc4

How reproducible:
Always

Steps to Reproduce:
1.Run Qcad
2.Play for a while with zooming in particukar
3.
  

Actual Results:  Crash

Expected Results:  Continue to run

Additional info:
Comment 1 Gérard Milmeister 2005-11-23 05:45:03 EST
Could you post somewhere an example drawing file, and
an exact description of the steps to perform that
result in a crash. Also indicate if you are using KDE
or GNOME, running qcad fullscreen, what screen size...
Comment 2 Gérard Milmeister 2005-11-23 05:47:22 EST
*** Bug 173900 has been marked as a duplicate of this bug. ***
Comment 3 antonio montagnani 2005-11-23 05:56:03 EST
Created attachment 121389 [details]
small lay-out in dxf format

as per your request
Comment 4 antonio montagnani 2005-11-23 05:57:14 EST
I am using Gnome
Comment 5 Gérard Milmeister 2005-11-23 06:31:25 EST
I zoomed in and out, changed grid size etc... I could not produce
a crash. Maybe it's a problem with your graphics setup. If you
can indicate an exact series of steps that will result in a crash,
please post it, otherwise it would be best to notify upstream.
Anyway, I noticed that a new src version has been published.
Comment 6 antonio montagnani 2005-11-23 06:34:54 EST
Did you try to zoom in/out many times in sequence??
And to stress grid???
Comment 7 Gérard Milmeister 2005-11-23 12:12:29 EST
Please try the new version:
http://math.ifi.unizh.ch/fedora/qcad-2.0.5.0-1.i386.rpm
Comment 8 antonio montagnani 2005-11-23 12:46:42 EST
Tnx Installed and from a really short test it seem ok.
I noticed that now I can change units of grid while in the previous release the
only choice was auto.

I will report any crash

Note You need to log in before you can comment on or make changes to this bug.