Bug 173928 - Dovecot imap and pop rejects valid user mailbox in mbox format
Dovecot imap and pop rejects valid user mailbox in mbox format
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 13:42 EST by David Kredba
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 17:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kredba 2005-11-22 13:42:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051022 Epiphany/1.6.4

Description of problem:
Today, after 8 days running after new installation of FC4 standalone mailserver
I got reports from dovecot in maillog like this :

Nov 22 11:26:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:26:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:26:40 d pop3(k): Couldn't open INBOX: Internal error occured. Refer to server log for more information. [2005-11-22 11:26:40]
Nov 22 11:27:40 d pop3-login: Login: k [11.11.11.11]
Nov 22 11:27:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:27:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:27:40 d pop3(k): Couldn't open INBOX: Internal error occured. Refer to server log for more information. [2005-11-22 11:27:40]
Nov 22 11:28:40 d pop3-login: Login: k [12.12.12.12]
Nov 22 11:28:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:28:40 d pop3(k): File isn't in mbox format: /var/mail/k
Nov 22 11:28:40 d pop3(k): Couldn't open INBOX: Internal error occured. Refer to server log for more information. [2005-11-22 11:28:40]
Nov 22 11:38:59 d imap-login: Login: k [127.0.0.1]
Nov 22 11:39:00 d imap-login: Login: k [127.0.0.1]
Nov 22 11:39:00 d imap(k): File isn't in mbox format: /var/mail/kovarova

The problem was "fixed" by dovecot restart.

Before that there is in /var/log/messages log of unsuccesful login attempts of mailbox owner :
Nov 22 11:31:27 d dovecot(pam_unix)[31388]: authentication failure; logname
= uid=0 euid=0 tty= ruser= rhost=  user=k
Nov 22 11:34:35 d dovecot(pam_unix)[31769]: authentication failure; logname
= uid=0 euid=0 tty= ruser= rhost=  user=k
Nov 22 11:34:52 d dovecot(pam_unix)[31793]: authentication failure; logname
= uid=0 euid=0 tty= ruser= rhost=  user=k
Nov 22 11:41:44 d dovecot(pam_unix)[32603]: authentication failure; logname
= uid=0 euid=0 tty= ruser= rhost=  user=k

The password sent by client was valid.


Mailbox is in perfect mbox format and dovecot is supporting it after its restart.

I must use there mbox format. Dovecot from fedora core 2 on another server is working with mbox format OK for a months without restart. It is dovecot-0.99.13-4.FC2.

There is some discussion on internet, that dovecot has buggy mbox support, like there : http://archives.neohapsis.com/archives/postfix/2005-07/0580.html

Thank You.

Version-Release number of selected component (if applicable):
dovecot-0.99.14-4.fc4

How reproducible:
Didn't try


Additional info:
Comment 1 Petr Rockai 2006-02-09 06:29:25 EST
Can you please try reproducing with new dovecot version? It is currently in   
rawhide (FC development) and will be in FC5test3. You may also want to wait   
for FC5. If it turns out that FC5 version still exhibits this behaviour, we   
can solve this in an update package. The version is 1.0 beta 2 and it should  
fix most mbox-related problems. There will also be an FC4 update with dovecot 
1.0b2 at some point after FC5test3, so you could test with that, too. 
Comment 2 David Kredba 2006-02-10 01:29:39 EST
I`ll try it. Thank you.
Comment 3 David Kredba 2006-02-24 13:21:39 EST
Hello. It seems to be working very well. Thank you.


(In reply to comment #2)
> I`ll try it. Thank you.

Comment 4 Petr Rockai 2006-04-03 17:58:23 EDT
The fc4 update to 1.0 beta was cancelled. The issue is however fixed in fc5. 
Backporting a fix is probably not feasible since the mbox code was rewritten 
in the meantime. Closing.

Note You need to log in before you can comment on or make changes to this bug.