Bug 173933 - a modified gdm conf file prevents gdm from starting after modular X upgrade
a modified gdm conf file prevents gdm from starting after modular X upgrade
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 14:47 EST by Christopher Blizzard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2005-11-22 14:47:11 EST
Description of problem:

If you have a modified gdm conf file it's not replaced when gdm is upgraded and
it contains a path to the X server.  Since the X server location has moved gdm
won't start up after a modular X upgrade.

Steps to Reproduce:
1. Modify your gdm.conf
2. Update to test1 (with modular X)
3. Note that gdm won't start with next boot

Actual results:

Warning about failing to start the X server

Expected results:

X Starts up.
Comment 1 Mike A. Harris 2005-11-23 00:31:35 EST
I think the best way to do this for now, is to have gdm hard code
/usr/bin/X which is the symlink pointing to the X server.  Now that
we're packaging X in FHS locations, it is highly probable that the
symlink will always be there.  I think I can almost guarantee it. ;)

Ray, what do you think?  kdm used to use Imake to find out where the
X server was, but that's broke now.  If you think autodetection is still
useful for this, we can probably get xorg to put a pkg-config variable
in the pc file.  That might be the best long-term solution.

Thoughts?
Comment 2 Matthew Miller 2007-04-06 12:42:10 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 3 Ray Strode [halfline] 2007-08-14 11:46:27 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.