Bug 173939 - su Not working from xterm
Summary: su Not working from xterm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 173763 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-22 20:27 UTC by jan vestby
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 23:10:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jan vestby 2005-11-22 20:27:59 UTC
Starting with nov 20 updates su does not work from xterm: 
[jan@hjemme ~]$ su - 
[jan@hjemme ~]$ 
 
stracing the operation terminates with: 
getuid32()                              = 500 
ioctl(0, SNDCTL_TMR_TIMEBASE or TCGETS, 0xbfd1fa48) = -1 ENOTTY (Inappropriate 
ioctl for device) 
write(2, "standard in must be a tty\n", 26) = 26 
close(1)                                = 0 
munmap(0xf3d000, 9680)                  = 0 
exit_group(1)                           = ? 
Process 6642 detached 
............................................. 
(well, it's not a tty....) 
Outside x it works as expected 
 
How reproducible: allways 
 
 
Steps to Reproduce: 
1. open xterminal 
2. type su - 
3. 
   
Actual results: nothing 
 
 
Expected results: prompted for password 
 
 
Additional info: i386 platform (P4 CPU) 
Maybe this is intended ? 
Maybe there is something funny with the configuration of the machine ?

Comment 1 Tim Waugh 2005-11-22 21:40:30 UTC
If you disable SELinux using 'setenforce 0', does the problem go away?

Comment 2 jan vestby 2005-11-22 23:01:52 UTC
Yes. Then the problem goes away. 
regards j.v 

Comment 3 Tim Waugh 2005-11-24 13:07:52 UTC
What does this say?:

rpm -q coreutils gnome-terminal selinux-policy-targeted selinux-policy-strict

I haven't been able to reproduce the problem here with Fedora Core 5test1.

Comment 4 jan vestby 2005-11-24 18:41:21 UTC
$ rpm -q coreutils gnome-terminal selinux-policy-targeted 
selinux-policy-strict 
coreutils-5.93-2 
gnome-terminal-2.12.0-1 
selinux-policy-targeted-2.0.0-1 
selinux-policy-targeted-2.0.4-1 
package selinux-policy-strict is not installed 
 
Believe I have defaults for everything related to selinux, though there seem 
to be 2 targeted policies. Had not noticed this before. 
 
Strange thing: Rebooting after yesterdays (nov 23) update made the problem 
disappear. 
 
regards 

Comment 5 Tim Waugh 2005-11-24 23:10:44 UTC
Okay, I suspect this was a bug in selinux-policy-targeted.  Please re-open if
you see this again.

Comment 6 Tim Waugh 2005-12-02 17:11:11 UTC
*** Bug 173763 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.