Bug 173941 - kernel crashes on boot
kernel crashes on boot
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 15:49 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 21:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Requested /etc/modprobe.conf file (441 bytes, text/plain)
2005-11-23 15:27 EST, Horst H. von Brand
no flags Details
Difference in contents of initrds (326 bytes, text/plain)
2005-11-23 15:48 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2005-11-22 15:49:18 EST
Description of problem:
Can't mount root filesystem from initrd. Last working kernel I tried is
2.6.14-1.1660_FC5.

Fully up-to-date rawhide.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1696_FC5 (also 1.1680_FC5)

How reproducible:
Always

Steps to Reproduce:
1. Boot...
2.
3.
  
Actual results:
...
Creating root device.
Mounting root filesystem.
mount: error: No such device or address mounting /dev/root on /sysroot as ext3
Setting up other filessytems
Setting up root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Expected results:
Boot ;-)

Additional info:
initrd is suspiciously small, only 937244 bytes, 1.1660 has 1397242.
Reinstalled the kernel to make sure it wasn't some glitch when installing it, no
change.

Everything (except /boot) is on LVM, SATA disk
Comment 1 Dave Jones 2005-11-23 01:13:10 EST
damn, you get all the oddball bugs :-)

that initrd size difference does sound odd. Does your /etc/modprobe.conf look sane ?

(Adding the mkinitrd maintainer to Cc:)
Comment 2 Horst H. von Brand 2005-11-23 15:27:01 EST
Created attachment 121412 [details]
Requested /etc/modprobe.conf file

The /etc/modprobe.conf file looks sane to me, and has worked forever on this
machine.

BTW, today's 2.6.14-1.1707_FC5 crashes just the same.
Comment 3 Horst H. von Brand 2005-11-23 15:48:39 EST
Created attachment 121413 [details]
Difference in contents of initrds

I just unpacked the initrd's for the working and last broken kernel. The reason
for the crash is crystal clear now: lvm is missing. See the attached "diff -u"
between the "ls -R"'s for both (oird is old, nird is new).

I just remade an initrd for the working kernel with mkinitrd-5.0.11-1, and it
shows no difference in contents to the original. And creating an initrd for the
new kernel shows no difference in contents to the working one...

Now booting 2.6.14-1.1707_FC5 with hand-built initrd... Yep, works.

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.