Bug 173982 - autofs and kernel crash when host name cannot be resolved in DNS.
autofs and kernel crash when host name cannot be resolved in DNS.
Status: CLOSED DUPLICATE of bug 173983
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 08:01 EST by Steve Traylen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 08:09:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Traylen 2005-11-23 08:01:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:

Hi 

  Since redhat exterprise 3 moved from 

  autofs-4.1.3-12

  to

  autofs-4.1.3-130

  we have found that for entry like 

  # /etc/auto.master
  /stage  /etc/auto.stage

  #/etc/auto.stage

  *  non-existant-host.stage.rl.ac.uk:/stage/&

  then a command such as 

  cd /stage/rhel3 

  hangs and the kernel crashes instantly when the hostname cannot be 
  resolved.

  From the changelog there were some changes in autofs in this area with
  this version.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-37.EL     autofs-4.1.3-130

How reproducible:
Always

Steps to Reproduce:
1. Install autofs-4.1.3-130
2. echo "/stage /etc/auto.stage" >> /etc/auto.master
3. echo "* non-existent-host.example.org:/stage/&" >> /etc/auto.stage
4. /etc/init.d/autofs restart
5. ls /stage/alpha




Actual Results:  autofs tries to nfs mount 

non-existent-host.example.org:/stage/alpha

presumably the DNS lookup fails

the ls command hangs and kernel panics.

Expected Results:  It should just inform you that is imposible to mount this filesystem with
a no such host as non-existent-host.example.org or something.

Additional info:



This unfortuantly hits us quite hard since we have always used a & in
the hostname in our mount map.

*     &.rl.ac.uk:/stage/&

and then maintain DNS aliases pointing at the various disks.

 Steve
Comment 1 Steve Traylen 2005-11-23 08:09:59 EST

*** This bug has been marked as a duplicate of 173983 ***

Note You need to log in before you can comment on or make changes to this bug.