Bug 173985 - /usr/share/doc/avahi-* has wrong permissions
/usr/share/doc/avahi-* has wrong permissions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 08:22 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: avahi-0.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 06:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-11-23 08:22:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
The avahi documentation isn't accessable by ordinary users as the permissions of the documet directory is set to 0644 instead of 0755.
It looks like one of the avahi Makefiles creates /usr/share/doc/avahi-*, this
task should be left to rpmbuild itself just by defining %doc somefiles.


Version-Release number of selected component (if applicable):
avahi-0.6-2

How reproducible:
Always

Steps to Reproduce:
1. cd /usr/share/doc/avahi-*  as an ordinary user
2. check error message
3.
  

Additional info:

avahi makefiles should create /usr/share/doc/avahi-*  at all
Comment 1 Jason Vas Dias 2005-11-30 14:35:37 EST
This bug is now fixed with avahi-0.6-3 
Comment 2 Karsten Hopp 2006-11-02 06:18:54 EST
verified fixed

Note You need to log in before you can comment on or make changes to this bug.