Bug 173987 - Compiled by default without utf-8 support
Compiled by default without utf-8 support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pcre (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 09:10 EST by Jon Lowell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 06:21:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Lowell 2005-11-23 09:10:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
compiled by default without utf-8 support

# pcretest -C
PCRE version 5.0 13-Sep-2004
Compiled with
  No UTF-8 support
  No Unicode properties support
  Newline character is LF
  Internal link size = 2
  POSIX malloc threshold = 10
  Default match limit = 10000000
  Match recursion uses stack


Version-Release number of selected component (if applicable):
pcre-5.0-4.1.fc4

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Ngo Than 2005-11-23 12:31:53 EST
strange, pcre-5.0-4.1.fc4 has been built with utf8 support.
With pcretest -C, i got this.

pcretest -C
PCRE version 5.0 13-Sep-2004
Compiled with
  UTF-8 support
  No Unicode properties support
  Newline character is LF
  Internal link size = 2
  POSIX malloc threshold = 10
  Default match limit = 10000000
  Match recursion uses stack


Could you please check if you have installed another pcre version on your machine?
Comment 2 Jon Lowell 2005-11-29 00:13:06 EST
Odd, I can't find another version of pcre lurking around my box.  This computer
has been upgraded from rh9 to fc4 though, not a clean install to say the least.
 I just tried reinstalling pcre from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/pcre-5.0-4.1.fc4.i386.rpm
and I'm still getting no utf8 support.

# rpm -qa | grep pcre
pcre-5.0-4.1.fc4
pcre-devel-5.0-4.1.fc4

I tore apart the SRPMS and can't see a problem.  Looks like this is an oddity
with my machine rather than a pcre bug, sorry about that!

Note You need to log in before you can comment on or make changes to this bug.