Bug 174014 - no longer accepts, and won't start with, --icmp-type any
no longer accepts, and won't start with, --icmp-type any
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 12:26 EST by John Ellson
Modified: 2008-02-06 11:01 EST (History)
9 users (show)

See Also:
Fixed In Version: 1.3.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-25 12:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-23 12:26:40 EST
Description of problem:
iptables no longer accepts, and won't start with, 
  -A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT

Version-Release number of selected component (if applicable):
iptables-1.3.4-1
kernel-2.6.14-1.1707_FC5

How reproducible:
100%

Steps to Reproduce:
1.service iptables restart
2.
3.
  
Actual results:
Applying iptables firewall rules: iptables-restore v1.3.4: Unknown arg `--icmp-type'
Error occurred at line: 11
Try `iptables-restore -h' or 'iptables-restore --help' for more information.
                                                           [FAILED]


Expected results:
upgrades should maintain backward compatibility, or make necessary corrections

Additional info:
Comment 1 John Ellson 2005-11-23 12:28:28 EST
I can comment out the --icmp-type any line and then start iptables, but then
the host doesn't respond correctly to ping.
Comment 2 Francis Jacobberger 2005-11-24 10:46:28 EST
Same here - ditto
Comment 3 Matthew Galgoci 2005-11-24 13:59:17 EST
<AOL>ME TOO!</AOL>
Comment 4 Jason 2005-11-24 19:34:15 EST
Ditto
Comment 5 Thomas Woerner 2005-11-25 12:13:05 EST
Fixed in rawhide in rpm iptables-1.3.4-2 or newer.
Comment 6 Jim Cornette 2005-11-25 20:18:23 EST
I'm effected by this bug as well. Even the Fedora mirror is vacant from the
revised version.
Adding to CC
Comment 7 Jim Cornette 2005-11-26 11:26:45 EST
iptables-1.3.4-2 works.
Comment 8 Edouard Bourguignon 2008-02-06 10:14:39 EST
Sorry but problem seems to be still here with iptables-1.3.8-6.fc9.i386 on F9 alpha.
Comment 9 Thomas Woerner 2008-02-06 10:41:55 EST
There have been a problem in system-config-firewall, which generates the rules
for iptables. Pleas update to system-config-firewall-1.2.2-1 from rawhide and
use "lokkit --update" afterwards.
Comment 10 Edouard Bourguignon 2008-02-06 11:01:06 EST
thanks that fix the problem

Note You need to log in before you can comment on or make changes to this bug.