Bug 174031 - selinux-policy-targeted - "missing whitespace" error
selinux-policy-targeted - "missing whitespace" error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 17:49 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 23:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-11-23 17:49:02 EST
Description of problem:

During installation the following shows up:

  Installing: selinux-policy-targeted      ##################### [104/224]
libsemanage.parse_assert_space: missing whitespace
(/etc/selinux/targeted/modules/tmp/seusers: 1):
root:root:s0-s0:c0.c255
libsemanage.seuser_parse: could not parse seuser record
libsemanage.dbase_file_cache: could not cache file database
libsemanage.enter_ro: could not enter read-only section
libsemanage.semanage_base_merge_components: could not merge local modifications
into policy
Failed!

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.0.4-1
Comment 1 Michal Jaegermann 2005-11-26 17:52:53 EST
I am seeing the same error now with selinux-policy-targeted-2.0.5-4 too.
In fact it prevents proper updates.  It was necessary to use 'rpm --force ...'
or, according to rpm, I am stuck forever with selinux-policy-targeted-2.0.4-1.
Comment 2 Stephen Warren 2005-12-05 23:45:45 EST
I see the same error messages here, *but* "rpm -q selinux-policy-targeted" shows
that the install did actually occur - no need to force it.

I installed fc5test1

I have been booting with selinux=0

On 2005/12/05 21:40 MST, I was actually able to get a "yum update" to go through
for the first time, which picked up selinux-policy-targeted-2.0.8-1

I haven't made any local modifications to the selinux config file (not knowingly
at least!)
Comment 3 Daniel Walsh 2005-12-06 10:54:02 EST
Did you see the same problem with 2.0.8-1?

Dan
Comment 4 Michal Jaegermann 2005-12-06 13:07:34 EST
> Did you see the same problem with 2.0.8-1?

No, I do not; but because of the other trouble described in bug #174953
I am not sure if this is masked, I am not getting that far, the other one
is really a different manifestation of the same, or this is truly gone.

Note You need to log in before you can comment on or make changes to this bug.