Bug 174045 - RHEL4: rcp outputs negative file size when over 2GB
RHEL4: rcp outputs negative file size when over 2GB
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsh (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2005-11-23 19:31 EST by JW
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0361
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 18:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Changes faulty %lld into a %llu, and enables largefile support (777 bytes, patch)
2005-11-23 19:33 EST, JW
no flags Details | Diff

  None (edit)
Description JW 2005-11-23 19:31:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
Rcp generates a negative number as the file size when size is over 2GB.


Version-Release number of selected component (if applicable):
rsh-0.17-29

How reproducible:
Always

Steps to Reproduce:
1.rcp file_over_2GB_in_size remotehost
2.
3.
  

Actual Results:  depends on client, but generally causes big problem because client gets negative file size

Expected Results:  rcp should proceed normally


Additional info:

POlease don't tell me to use scp - this is a bug about rcp.
Comment 1 JW 2005-11-23 19:33:01 EST
Created attachment 121428 [details]
Changes faulty %lld into a %llu, and enables largefile support
Comment 2 Karel Zak 2005-11-24 04:54:59 EST
Thanks. Fixed in devel (FC5) branche. I'm going to fix it in FC4 next week.
Comment 3 Karel Zak 2005-11-28 10:04:34 EST
FC4 version has been fixed. Note -- this report is also valid for RHEL3|4. 
Comment 10 Red Hat Bugzilla 2006-05-10 18:08:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0361.html

Note You need to log in before you can comment on or make changes to this bug.