Bug 174056 - sox doesn't use alsa
Summary: sox doesn't use alsa
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-24 04:37 UTC by Matt Domsch
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 12.18..1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 16:42:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Domsch 2005-11-24 04:37:42 UTC
Description of problem:
As noted in #155224, sox isn't using alsa-lib, as it should be able to.  This
prevents sox from directly using alsa.

Version-Release number of selected component (if applicable):
sox-12.17.7-3

Comment 1 Thomas Woerner 2005-11-29 13:39:45 UTC
The alsa header files are missing in glibc-kernheaders.

Assigning to glibc-kernheaders.

Comment 2 David Woodhouse 2005-11-29 13:46:21 UTC
Shouldn't that be alsa-devel? Userspace shouldn't be looking at kernel headers.

Comment 3 Matthias Saou 2005-11-29 14:47:11 UTC
Yeah, I think we all agreed that the actual issue was that sox uses the kernel
headers to enable ALSA support, when it should be using the alsa-lib layer
instead. So this should be considered a bug in sox unless I'm mistaken.

Comment 4 Chris Bagwell 2005-11-29 15:25:08 UTC
I'm mantainer of SoX... On seperate mail list it was agreed best would be for
SoX to change to alsa-lib.  Current upstream CVS version of SoX has changed its
alsa driver to use alsa-lib so the next release of SoX (12.17.9) will make this
a non-issue.

The next release of SoX will occur any day now.

Besides the above, it is strange to me that sys/soundcard.h is important enough
to be in glibc-headers but not ALSA headers.  Technically, I'd think
sys/soundcard.h should be in glib-kernelheaders, not glib-headers since its an
interface to a kernel driver.

But moving sys/soundcard.h to kernelheaders would kill compiles for about all
OSS drivers, in the same way that SoX currently can't compile with ALSA.

Comment 5 Matt Domsch 2006-10-12 16:42:13 UTC
sox-12.18.1-1 or earlier uses libasound now.  Closing.


Note You need to log in before you can comment on or make changes to this bug.