Bug 174069 - spec file doesnt allow for non-selinux compile
spec file doesnt allow for non-selinux compile
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 04:58 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 05:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
allow for optional selinux and audit compilation (1.82 KB, patch)
2005-11-24 05:04 EST, JW
no flags Details | Diff

  None (edit)
Description JW 2005-11-24 04:58:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
The spec file doesn allow for non-selinux compilation


Version-Release number of selected component (if applicable):
util-linux-2.12p-9.12

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild -v -ba --define "WITH_SELINUX 0" util-linux.spec
2.
3.
  

Actual Results:  All utilities have selinux linkage


Expected Results:  There should be no reference to selinux


Additional info:

I also now understand why readahead and prelink exist - pam+selinux+audit create serious startup overhead.

Are you sure MS hasn't being buying up RH shares?  Are they trying to do to RH/Linux what they did to SCO Linux?
Comment 1 JW 2005-11-24 05:04:33 EST
Created attachment 121440 [details]
allow for optional selinux and audit compilation
Comment 2 Karel Zak 2005-11-24 05:59:10 EST
Sorry, but our packages are optimalized for our distribution(s). We don't have
resources and effort to support arbitrary packages customization.

Closing as WONTFIX.
Comment 3 JW 2005-11-24 06:15:39 EST
(In reply to comment #2)
> Sorry, but our packages are optimalized for our distribution(s). We don't have
> resources and effort to support arbitrary packages customization.
> 
> Closing as WONTFIX.

That's ok because I created the patch for free.
No need to thank me for it though.

BTW you had the resources to create SeLinux in the first place. Pity you never
had the resources to implement your code in a modular fashion.  You get what you
pay for I suppose.

Note You need to log in before you can comment on or make changes to this bug.