Bug 174070 - Segfault with no LANG in environment
Segfault with no LANG in environment
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 05:00 EST by Andy Shevchenko
Modified: 2013-07-02 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 05:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix for described problem (451 bytes, patch)
2005-11-24 05:00 EST, Andy Shevchenko
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2005-11-24 05:00:14 EST
Description of problem:
mc segfaults when LANG evnvironment variable not set. This is usual situation 
for chroot setup (buildroots, chrooted servers, etc.)

Version-Release number of selected component (if applicable):
Last FC3/4 updates.

How reproducible:
Just unset LANG and try to run.

Actual results:
Segfault.

Expected results:
No segfault.


Additional info:
See attached simple patch which fixes incorrect handle with getenv() return 
value.
Comment 1 Andy Shevchenko 2005-11-24 05:00:14 EST
Created attachment 121439 [details]
fix for described problem
Comment 2 Jindrich Novy 2005-11-24 10:06:37 EST
Oops, I forgot to check the impossible ;)
Comment 3 Jindrich Novy 2005-12-01 05:18:48 EST
This is now fixed since mc-4.6.1a-3.FC4.

Note You need to log in before you can comment on or make changes to this bug.