Bug 1740790 - Tasks search filter parse wrongly filter 'xy' seconds ago
Summary: Tasks search filter parse wrongly filter 'xy' seconds ago
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-13 15:43 UTC by tstrych
Modified: 2021-07-22 07:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-19 21:34:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github wvanbergen scoped_search issues 188 0 None open Query language - Temporal comparisons do not support seconds 2021-02-03 12:07:35 UTC

Description tstrych 2019-08-13 15:43:06 UTC
Description of problem:
When this filter 'started_at > "10 seconds ago"' is searched in Tasks. There are two options result is zero results or all possible results (also older then 10 seconds, in this case).

Version-Release number of selected component (if applicable):
Sat 6.6 snap 15

How reproducible:
It's always zero results or all. I didn't find any connection when the results are empty and when all are shown.

Steps to Reproduce:
1. Navigate to Monitor->Tasks
2. Filter 'started_at > "xy seconds ago"'
3. Shows all results or zero results.

Actual results:
Filter doesn't meet the results of filter requirements.

Expected results:
Filter meet the results of filter requirements. It is possible to use 'started_at > "10 seconds ago"' with the right results.

Additional info:
It doesn't work with seconds, but it work with minutes.
This problem was already discussed with aruzicka. It seems problems is in scoped_search - query language, probably it doesn't support seconds. Issue on GitHub is created and link is provided in links section of this bz.

Comment 3 Mike McCune 2020-12-09 22:18:23 UTC
Upon review of our valid but aging backlog the Satellite Team has concluded that this Bugzilla does not meet the criteria for a resolution in the near term, and are planning to close in approximately a month. If you have any concerns about this, please contact your Red Hat Account team.  Thank you.

Comment 4 Mike McCune 2021-01-19 21:27:47 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.