Bug 174086 - NFS-Client consumes all memory by putting larg files
NFS-Client consumes all memory by putting larg files
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 06:57 EST by Falko Pilz
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 14:50:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Falko Pilz 2005-11-24 06:57:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
Our Environment ist this: 
one computer is a RHEL4 AS on 4way Xeon (i386) with 20 GB RAM (here as NFS-Server)
the other is a RHEL 3 AS on S390 (here as NFS-Server)

If we write a file larger than the available memory, the application works until all of the memory is used, than the applikation crashes with an "out of memory" message.
If we copy or move such a file, the crash happens as a kernel panic saying something like that: "no more memory available, no processes to kill"

There isn't at no time any swapping be done.

Version-Release number of selected component (if applicable):
kernel-2.6.9-5ELsmp

How reproducible:
Always

Steps to Reproduce:
1. We have a file nearly 22GB large, if we save, copy or move them on a NFS-mounted directory

Actual Results:  Applikation or kernel crashes

Expected Results:  The move, copy or save should succeed

Additional info:
Comment 1 Steve Dickson 2005-12-09 07:52:32 EST
Please post a snap shot of the system memory when this happens
by doing a sysrq-M (or echo m > /proc/sysrq-trigger). The output
will be in /var/log/messages.

Also a system backtrace at this point might prove to be useful as
well... Use sysrq-T or 'echo t > /proc/sysrq-trigger" which also
dumps the backtrace in /var/log/messages.

Comment 3 Larry Woodman 2005-12-15 13:40:43 EST
Please attach the console output that this show_free_areas() prints out just
before the panic:

--------------------------------------------------------------------------
        p = select_bad_process();
                                                                               
                        
        /* Found nothing?!?! Either we hang forever, or we panic. */
        if (!p) {
                show_free_areas();
                panic("Out of memory and no killable processes...\n");
        }
                                                                               
                       
--------------------------------------------------------------------------


Thanks, Larry Woodman
Comment 8 Steve Dickson 2006-11-01 14:50:04 EST
Being there has not been any outside activity on the bug
since its been open '2005-11-24' I'm going to close this as
not a bug.... please feel free to reopen if this is not the case... 

Note You need to log in before you can comment on or make changes to this bug.