Bug 1740942 - Ironic nodes registered to the bmo Ironic are in 'adopt failed' state
Summary: Ironic nodes registered to the bmo Ironic are in 'adopt failed' state
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Kubernetes-native Infrastructure
Classification: Red Hat
Component: Deployment
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-13 22:32 UTC by Marius Cornea
Modified: 2020-04-06 13:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-26 13:48:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2019-08-13 22:32:09 UTC
Description of problem:
After deployment has succeeded, checking the Ironic nodes state we can see they're in adopt failed state:

[cloud-user@rhhi-node-worker-0 dev-scripts]$ export OS_URL=http://172.22.0.3:6385
[cloud-user@rhhi-node-worker-0 dev-scripts]$ export OS_TOKEN=fake-token
[cloud-user@rhhi-node-worker-0 dev-scripts]$ openstack baremetal node list
+--------------------------------------+--------------------+---------------+-------------+--------------------+-------------+
| UUID                                 | Name               | Instance UUID | Power State | Provisioning State | Maintenance |
+--------------------------------------+--------------------+---------------+-------------+--------------------+-------------+
| 56904f3a-88da-4ea9-b237-155216d12d9d | openshift-master-0 | None          | power on    | adopt failed       | False       |
| 21466e2a-a0c5-4a0e-ae4b-788e02c4fa0c | openshift-master-1 | None          | power on    | adopt failed       | False       |
| 1b48b778-d341-4e21-ad9e-a49ae9619ed1 | openshift-master-2 | None          | power on    | adopt failed       | False       |
+--------------------------------------+--------------------+---------------+-------------+--------------------+-------------+

[cloud-user@rhhi-node-worker-0 dev-scripts]$ openstack baremetal node show 56904f3a-88da-4ea9-b237-155216d12d9d | grep error
| last_error             | Error while attempting to adopt node 56904f3a-88da-4ea9-b237-155216d12d9d: Cannot validate image information for node 56904f3a-88da-4ea9-b237-155216d12d9d because one or more parameters are missing from its instance_info and insufficent information is present to boot from a remote volume. Missing are: ['ramdisk', 'kernel', 'image_source'].

Version-Release number of selected component (if applicable):
quay.io/metal3-io/ironic:master
quay.io/metal3-io/ironic@sha256:7a6d623576d2c8833f41cfee05fbf36a5171a48ccdb7d2ebb1b00edb32c63892


How reproducible:
100%

Steps to Reproduce:
1. Deploy
2. export OS_URL=http://172.22.0.3:6385
   export OS_TOKEN=fake-token
3. openstack baremetal node list

Actual results:
Nodes in adopt failed state.

Expected results:
Nodes in active state.

Additional info:

Comment 1 Doug Hellmann 2019-08-23 22:39:37 UTC
This should have been resolved by https://github.com/metal3-io/baremetal-operator/pull/278

Is this still an issue?

Comment 2 Marius Cornea 2019-08-26 13:48:44 UTC
(In reply to Doug Hellmann from comment #1)
> This should have been resolved by
> https://github.com/metal3-io/baremetal-operator/pull/278
> 
> Is this still an issue?

No, the issue is not reproducible anymore.


Note You need to log in before you can comment on or make changes to this bug.