Bug 174106 - ICE with complex statement function in gfortran
ICE with complex statement function in gfortran
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 11:18 EST by Alexander Täschner
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 04:50:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Täschner 2005-11-24 11:18:10 EST
The code listed below gives an internal compiler error while
compiling:

[taschna@localhost ~]$ cat hwhigy.f
      SUBROUTINE HWHIGY
      IMPLICIT NONE
      COMPLEX C0,Z
      DOUBLE PRECISION A

      C0(Z,A)=Z+A

      END
[taschna@localhost ~]$ gfortran -v
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-libgcj-multifile
--enable-languages=c,c++,objc,java,f95,ada --enable-java-awt=gtk
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --host=i386-redhat-linux
Thread model: posix
gcc version 4.0.2 20051109 (Red Hat 4.0.2-6)
[taschna@localhost ~]$ gfortran -c hwhigy.f
hwhigy.f:0: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Comment 1 Alexander Täschner 2005-11-25 02:37:50 EST
With gfortran version 4.0.1-6 (20050729) this code compiles without error.
Comment 2 Jakub Jelinek 2005-11-29 04:50:27 EST
Seems to be fixed recently on both gcc-4_0-branch and gcc-4_1-branch/trunk,
i.e. I can reproduce it with gcc-gfortran-4.0.2-6, I can't with
gcc-gfortran-4.0.2-8.fc4 (currently in FC4 updates testing) nor with
gcc-gfortran-4.1.0-0.2 (new rawhide compiler in the works).
So it got fixed between 9th and 25th November.

Note You need to log in before you can comment on or make changes to this bug.