Bug 174125 - pup crashes while trying to update directb
pup crashes while trying to update directb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
:
: 174136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 16:05 EST by Jukka Ketelaars
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 22:32:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jukka Ketelaars 2005-11-24 16:05:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Trying to update only directfb, pup crashes with a traceback.

Version-Release number of selected component (if applicable):
pup-0.1.6-1

How reproducible:
Always

Steps to Reproduce:
1. Start pup
2. select only directfb (directfb - 0.9.24-2.fc5.i386 updates directfb - 0.9.22-2.fc4.i386)
3. Press "Apply updates"
  

Actual Results:  Traceback (most recent call last):
  File "/usr/share/pup/pup/pup.py", line 536, in _apply
    self._checkDeps()
  File "/usr/share/pup/pup/pup.py", line 778, in _checkDeps
    _("Unable to resolve dependencies for some "
  File "/usr/share/pup/pup/pup.py", line 131, in __init__
    i.set_from_stock(self._get_stock_from_type(type), 6)
AttributeError: 'NoneType' object has no attribute 'set_from_stock'

> /usr/share/pup/pup/pup.py(131)__init__()
-> i.set_from_stock(self._get_stock_from_type(type), 6)
(Pdb)


Expected Results:  A message should have been displayed that directfb can not be installed due to missing dependencies.

Additional info:

yum update directb gives the following output:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package directfb.i386 0:0.9.24-2.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libdirectfb-0.9.so.22 for package: mplayer
--> Finished Dependency Resolution
Error: Missing Dependency: libdirectfb-0.9.so.22 is needed by package mplayer
Comment 1 Jeremy Katz 2005-11-24 22:32:52 EST
Hrmm, looks like part of the glade file got lost somehow.  Fixed for pup-0.1.7
which should be in rawhide tomorrow
Comment 2 Jeremy Katz 2005-11-24 22:34:46 EST
*** Bug 174136 has been marked as a duplicate of this bug. ***
Comment 3 David Lawrence 2006-06-27 21:35:09 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.