Bug 174139 - Faulty magic database entry triggers erroneously
Faulty magic database entry triggers erroneously
Status: CLOSED DUPLICATE of bug 174137
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 19:53 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 01:57:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix fault in magic file (419 bytes, patch)
2005-11-24 20:00 EST, JW
no flags Details | Diff

  None (edit)
Description JW 2005-11-24 19:53:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
There is a faulty entry in /usr/share/file/magic in "cracklib" section which triggers on just about every binary file.


Version-Release number of selected component (if applicable):
file-4.15-fc4.1

How reproducible:
Always

Steps to Reproduce:
1./usr/bin/file /var/lib/rpm/Basenames
2.
3.
  

Actual Results:  Basenames: (1628767744 words)

Expected Results:  Basenames: data


Additional info:

The expected result wont happen until the other bug (#174137) is fixed.
But the test file is not a cracklib password index!
And lots of other binary files produce the same result.
It is caused be a simple bug in new cracklib entry in magic file.
See patch for a fix.
Comment 1 JW 2005-11-24 20:00:20 EST
Created attachment 121470 [details]
Patch to fix fault in magic file

To apply:
     cd /usr/share/file
     patch -p0 <magic.patch
     rm magic.mgc
     file -C
Comment 2 Fedora Update System 2005-11-28 13:29:58 EST
From User-Agent: XML-RPC

file-4.16-fc4.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 JW 2005-11-28 20:53:27 EST
(In reply to comment #2)
> From User-Agent: XML-RPC
> 
> file-4.16-fc4.1 has been pushed for FC4, which should resolve this issue.  If
these problems are still present in this version, then please make note of it in
this bug report.

No, the issue is not resolved!
Why do you close bugs when you haven't even tested them?

I have gone to the trouble of even supplying a patch to fix the problem, yet you
ignore the patch, close the bug, don't even test it ... what exactly are you
trying to achieve?
Comment 4 Radek Vokal 2005-11-29 01:57:59 EST
Slow down please, here's my output

root@gigolo ~# rpm -q file
file-4.16-fc4.1
root@gigolo ~# file /var/lib/rpm/Basenames
/var/lib/rpm/Basenames: Berkeley DB (Hash, version 8, native byte-order)

Do you consider it wrong? I don't.
Comment 5 JW 2005-11-29 03:12:09 EST
> Do you consider it wrong? I don't.

Please see my comments for bug #174137 (they are both the result of the same error).

And to answer your question truthfully, yes, it is wrong. And, yes, I know that
you don't consider it to be.




*** This bug has been marked as a duplicate of 174137 ***

Note You need to log in before you can comment on or make changes to this bug.