Bug 174156 - Cannot automount NFS directories with auto.net
Cannot automount NFS directories with auto.net
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 05:10 EST by Mogens Kjaer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 03:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mogens Kjaer 2005-11-25 05:10:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
I use /etc/auto.net to mount NFS shares on
other machines.

This works in FC3 and FC4, but not in FC5t1

I get the following in /var/log/messages:

Nov 25 11:07:08 leg2 kernel: net/sunrpc/rpc_pipe.c: rpc_lookup_parent failed to find path /nfs/clntc
Nov 25 11:07:08 leg2 kernel: RPC: Couldn't create pipefs entry /nfs/clntc, error -2
Nov 25 11:07:08 leg2 automount[3384]: >> mount: special device server2:/home does not exist
Nov 25 11:07:08 leg2 automount[3384]: mount(nfs): nfs: mount failure server2:/home on /net/server2/home
Nov 25 11:07:08 leg2 automount[3384]: >> mount: server2:/var/www/html failed, reason given by server: Permission denied
Nov 25 11:07:08 leg2 automount[3384]: mount(nfs): nfs: mount failure server2:/var/www/html on /net/server2/var/www/html
Nov 25 11:07:08 leg2 kernel: net/sunrpc/rpc_pipe.c: rpc_lookup_parent failed to find path /nfs/clntd
Nov 25 11:07:08 leg2 kernel: RPC: Couldn't create pipefs entry /nfs/clntd, error -2
Nov 25 11:07:08 leg2 automount[3384]: >> mount: special device server2:/home/pcsupport does not exist
Nov 25 11:07:08 leg2 automount[3384]: mount(nfs): nfs: mount failure server2:/home/pcsupport on /net/server2/home/pcsupport

when I try to access /net/server2/home.

"/etc/auto.net server2" prints:

-fstype=nfs,hard,intr,nodev,nosuid \
        /home server2:/home \
        /home/pcsupport server2:/home/pcsupport \
        /var/www/html server2:/var/www/html

This is identical to what I get on a FC4 machine.

I can do the mount manually:

mount server2:/home /mnt/test

without any problems.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /net/server2/home
2. ls

  

Actual Results:  I only see the folder pcsupport, which isn't
exported to this machine

Expected Results:  A list of people's home directories.

Additional info:
Comment 1 Mogens Kjaer 2005-11-25 06:48:04 EST
Argh, the reason for this was bug 174104, disabling selinux again solves this
problem.
Comment 2 Daniel Walsh 2005-11-28 13:26:45 EST
Look in /var/log/messages and /var/log/audit/audit.log for AVC messages?  

These will tell what SELinux has a problem with.
Comment 3 Mogens Kjaer 2005-11-29 02:29:57 EST
The only thing I know about selinux is how to disable it
at installation...

Anyway, here's what is logged:

...
type=USER_START msg=audit(1132910666.073:24): user pid=2842 uid=0
auid=4294967295 msg='PAM: session open acct=mk : exe="/bin/su" (hostname=?,
addr=?, terminal=pts/2 res=success)'
type=CRED_ACQ msg=audit(1132910666.073:25): user pid=2842 uid=0 auid=4294967295
msg='PAM: setcred acct=mk : exe="/bin/su" (hostname=?, addr=?, terminal=pts/2
res=success)'
type=AVC msg=audit(1132911614.986:26): avc:  denied  { search } for  pid=3147
comm="mount" name="/" dev=rpc_pipefs ino=5473
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:rpc_pipefs_t:s0
tclass=dir
type=SYSCALL msg=audit(1132911614.986:26): arch=40000003 syscall=21 success=no
exit=-2 a0=8641f78 a1=8641f90 a2=8641fa8 a3=c0ed0006 items=1 pid=3147
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="mount" exe="/bin/mount"
type=CWD msg=audit(1132911614.986:26):  cwd="/net"
type=PATH msg=audit(1132911614.986:26): item=0 name="/net/server2/home" flags=1
 inode=10178 dev=00:16 mode=040555 ouid=0 ogid=0 rdev=00:00
type=AVC msg=audit(1132911615.098:27): avc:  denied  { search } for  pid=3149
comm="mount" name="/" dev=rpc_pipefs ino=5473
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:rpc_pipefs_t:s0
tclass=dir
type=SYSCALL msg=audit(1132911615.098:27): arch=40000003 syscall=21 success=no
exit=-2 a0=849ef78 a1=849ef98 a2=849efb8 a3=c0ed0006 items=1 pid=3149
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="mount" exe="/bin/mount"
type=CWD msg=audit(1132911615.098:27):  cwd="/net" 
type=PATH msg=audit(1132911615.098:27): item=0
name="/net/server2/home/pcsupport" flags=1  inode=10210 dev=00:16 mode=040555
ouid=0 ogid=0 rdev=00:00
type=USER_AUTH msg=audit(1132912101.937:28): user pid=3196 uid=0 auid=4294967295
msg='PAM: authentication acct=root : exe="/usr/sbin/sshd" (hostname=mk.crc.dk,
addr=172.20.2.11, terminal=ssh res=success)'
...
Comment 4 Nils Philippsen 2005-12-05 10:25:36 EST
Happens for me as well -- although I don't get any audit messages pertaining
this issue. Trying to access an autofs share yields exactly this:

Dec  5 16:19:30 ls3505 kernel: net/sunrpc/rpc_pipe.c: rpc_lookup_parent failed
to find path /nfs/clnt2c
Dec  5 16:19:30 ls3505 kernel: RPC: Couldn't create pipefs entry /nfs/clnt2c,
error -2
Dec  5 16:19:30 ls3505 automount[4994]: >> mount: special device
nsl01a:/vol/linuxlab does not exist
Dec  5 16:19:30 ls3505 automount[4994]: mount(nfs): nfs: mount failure
nsl01a:/vol/linuxlab on /misc/filer
Dec  5 16:19:30 ls3505 automount[4994]: failed to mount /misc/filer

"setenforce 0" works around the problem here as well.
Comment 5 Jeffrey Moyer 2006-03-07 17:07:54 EST
Changing to NEEDINFO_REPORTER from NEEDINFO.
Comment 6 Mike Jang 2006-03-28 13:37:22 EST
(In reply to comment #5)
> Changing to NEEDINFO_REPORTER from NEEDINFO.

What info is needed?
Comment 7 Jeffrey Moyer 2006-05-23 13:04:30 EDT
see comment #2 for the requested information.

It would be good to know if this is still a problem.
Comment 8 Mogens Kjaer 2006-05-24 03:18:59 EDT
No, the problem is fixed in FC5 with the all updates.

Note You need to log in before you can comment on or make changes to this bug.