Bug 174159 - No queue created when attaching USB printer
No queue created when attaching USB printer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 06:26 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 13:33:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-11-25 06:26:53 EST
Description of problem:
No queue is created when I attach a USB printer (HP DeskJet 990C).

Version-Release number of selected component (if applicable):
hal-cups-utils-0.5.3-3
dbus-0.50-1
hal-0.5.5.1-1
udev-075-4
system-config-printer-0.6.145-1
kernel-2.6.14-1.1707_FC5
kernel-2.6.14-1.1709_FC5
selinux-policy-targeted-2.0.5-3

How reproducible:
100%

Steps to Reproduce:
1. Install FC5 test 1 with USB printer attached and switched on.
2. Examine 'lpstat -s' output.
  
Actual results:
No queue created for local printer.

Expected results:
Queue.

Additional info:
'/sbin/service cups reload' does *not* fix this.
SELinux is enabled, with 'targeted' policy.

When I disable SELinux using 'setenforce 0' and re-attach the printer, a queue
is created.  Here is audit.log, cleared out before the printer was attached:

type=AVC msg=audit(1132918139.315:146): avc:  denied  { read } for  pid=17048
comm="killall" name="stat" dev=proc ino=128057358
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:initrc_t:s0 tclass=file
type=SYSCALL msg=audit(1132918139.315:146): arch=40000003 syscall=5 success=yes
exit=3 a0=8dcd8d0 a1=8000 a2=1b6 a3=8dcd678 items=1 pid=17048 auid=4294967295
uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="killall"
exe="/usr/bin/killall"
type=CWD msg=audit(1132918139.315:146):  cwd="/"
type=PATH msg=audit(1132918139.315:146): item=0 name="/proc/1954/stat" flags=101
 inode=128057358 dev=00:03 mode=0100444 ouid=0 ogid=0 rdev=00:00
type=AVC msg=audit(1132918139.315:147): avc:  denied  { getattr } for  pid=17048
comm="killall" name="stat" dev=proc ino=128057358
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:initrc_t:s0 tclass=file
type=SYSCALL msg=audit(1132918139.315:147): arch=40000003 syscall=197
success=yes exit=0 a0=3 a1=bfa7cf0c a2=746ff4 a3=3 items=0 pid=17048
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="killall" exe="/usr/bin/killall"
type=AVC_PATH msg=audit(1132918139.315:147):  path="/proc/1954/stat"
type=AVC msg=audit(1132918139.323:148): avc:  denied  { read } for  pid=17048
comm="killall" name="stat" dev=proc ino=137232398
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:crond_t:s0 tclass=file
type=SYSCALL msg=audit(1132918139.323:148): arch=40000003 syscall=5 success=yes
exit=3 a0=8dcd8d0 a1=8000 a2=1b6 a3=8dcd678 items=1 pid=17048 auid=4294967295
uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="killall"
exe="/usr/bin/killall"
type=CWD msg=audit(1132918139.323:148):  cwd="/"
type=PATH msg=audit(1132918139.323:148): item=0 name="/proc/2094/stat" flags=101
 inode=137232398 dev=00:03 mode=0100444 ouid=0 ogid=0 rdev=00:00
type=AVC msg=audit(1132918139.323:149): avc:  denied  { getattr } for  pid=17048
comm="killall" name="stat" dev=proc ino=137232398
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:crond_t:s0 tclass=file
type=SYSCALL msg=audit(1132918139.323:149): arch=40000003 syscall=197
success=yes exit=0 a0=3 a1=bfa7cf0c a2=746ff4 a3=3 items=0 pid=17048
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="killall" exe="/usr/bin/killall"
type=AVC_PATH msg=audit(1132918139.323:149):  path="/proc/2094/stat"
type=AVC msg=audit(1132918151.971:150): avc:  denied  { read } for  pid=17108
comm="killall" name="stat" dev=proc ino=117440526
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:auditd_t:s0 tclass=file
type=SYSCALL msg=audit(1132918151.971:150): arch=40000003 syscall=5 success=yes
exit=3 a0=8a018d0 a1=8000 a2=1b6 a3=8a01678 items=1 pid=17108 auid=4294967295
uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="killall"
exe="/usr/bin/killall"
type=CWD msg=audit(1132918151.971:150):  cwd="/"
type=PATH msg=audit(1132918151.971:150): item=0 name="/proc/1792/stat" flags=101
 inode=117440526 dev=00:03 mode=0100444 ouid=0 ogid=0 rdev=00:00
type=AVC msg=audit(1132918151.971:151): avc:  denied  { getattr } for  pid=17108
comm="killall" name="stat" dev=proc ino=117440526
scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:auditd_t:s0 tclass=file
type=SYSCALL msg=audit(1132918151.971:151): arch=40000003 syscall=197
success=yes exit=0 a0=3 a1=bfe4913c a2=238ff4 a3=3 items=0 pid=17108
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="killall" exe="/usr/bin/killall"
type=AVC_PATH msg=audit(1132918151.971:151):  path="/proc/1792/stat"
Comment 1 Rahul Sundaram 2006-02-20 06:32:48 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Note You need to log in before you can comment on or make changes to this bug.