Bug 174183 - Firefox stuck when opening additional window or dialogue box
Firefox stuck when opening additional window or dialogue box
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 09:56 EST by Vladimir Kosovac
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 06:33:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 305970 None None None Never

  None (edit)
Description Vladimir Kosovac 2005-11-25 09:56:11 EST
Description of problem:
Upon starting browser, first dialogue box or other firefox component that tries
to open a window (Bookmarks Manager for example) temporary freezes the browser
for maybe 10 seconds. /var/log/messages has an entry like:

#######################################################
Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only
configuration source at position 0

Nov 26 03:00:23 localhost gconfd (dovla-5847): Resolved address
"xml:readwrite:/home/dovla/.gconf" to a writable configuration source at position 1

Nov 26 03:00:23 localhost gconfd (dovla-5847): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2

Nov 26 03:00:26 localhost gconfd (dovla-5847): Resolved address
"xml:readwrite:/home/dovla/.gconf" to a writable configuration source at position 0
====================================================================

Then it resumes normally and subsequent dialogue boxes or other windows open
from menu do not show this behavior.

Version-Release number of selected component (if applicable):

firefox-1.5-0.5.0.rc3


How reproducible:

every time upon running firefox

Steps to Reproduce:
1. Start firefox
2. Open url that wants to set the cookie (or open Bookmark Manager)
3. Firefox freezes for number (10) seconds
  
Actual results:
See above - 3.

Expected results:

Ability to respond to dialogue 

Additional info:
Comment 1 Daniel Malmgren 2005-11-28 07:12:06 EST
I'd just like to confirm. I get this on a totally fresh FC5t1 installation. I'd
rather say 20 seconds freeze for me though...
Comment 2 Partha Bagchi 2005-11-28 16:22:59 EST
I would like to confirm that this happens to me whenever a dialog box is opened
(such as downloads). The CPU usage goes to 100% and firefox freezes for maybe
5-10 seconds and then resumes.
Comment 3 n0dalus 2005-12-01 02:20:54 EST
This has been (mostly) fixed upstream.
Once the 1.5 packages come out in the repos, update and it should fix this issue.
Comment 4 Vladimir Kosovac 2005-12-01 03:17:09 EST
Apparently this bug is fixed in Firefox 1.5 final - tarball available on
getfirefox.com does not show this behaviour.
Comment 5 Rahul Sundaram 2006-02-20 06:33:54 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Note You need to log in before you can comment on or make changes to this bug.