Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1742009 - Provisioning fails with error InvalidDeviceSpec: Invalid configuration for device '2'.
Summary: Provisioning fails with error InvalidDeviceSpec: Invalid configuration for de...
Keywords:
Status: CLOSED DUPLICATE of bug 1724780
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: 6.6.0
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-16 14:39 UTC by Suraj Patil
Modified: 2019-09-09 21:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-09 21:16:32 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Suraj Patil 2019-08-16 14:39:00 UTC
Description of problem:
Unable to create the host in the first go and fails with the below error. 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Failed to create a compute vmware (VMware) instance ramon-hallihan.example.com: InvalidDeviceSpec: Invalid configuration for device '2'. 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Reason for this is that storage details are not passed in the fog API.
This only happens in the case of hostgroup. 

Observation- 
When we create the new host and select the hostgroup, then in the "Virtual Machine" tab we can see that whole Storage block is not present, though storage details are present in the compute profile and compute profile is present in the hostgroup. 

Once it fails with the above error, then we can go to "Virtual Machine" tab see that Storage block appears but still values are not populated. 

Version-Release number of selected component (if applicable):
Satellite 6.6


How reproducible:


Steps to Reproduce:
1. Create the hostgroup with all the details(compute resource and compute profile).
2. Make sure storage details are present in compute profile. 
3. Hosts > Create new host > select host group. 
4. Go to Virtual Machine tab, It is observed that Storage block is not present. 
5. click submit. It will fail with above error. 
6. GO again to Virtual Machine tab. You will now see the Storage block, but values are still not present. 


Actual results:
After selecting hostgroup, storage details are not populated. 

Expected results:
Storage details should automatically populate.

Comment 5 Marek Hulan 2019-08-19 11:41:40 UTC
This does not feel as vmware specific issue. Based on the reproducing steps, it more looks like the JS fails to load react components for the storage part of the VM tab. I think Ondrej was looking into something like this very recently, Ondrej, could you please take a look? I would assume it only happens after selecting hostgroup (similar issue for ansible roles switcher)

Comment 6 Ondřej Ezr 2019-08-20 01:01:12 UTC
The resulting error message is vmware error, but the issue with the storages not being present is probably the real cause and it is an issue I'm working on. I have been able to reduce the occurence in my environment, being like 20% random. I'm wtill working on finding the true cause.

Comment 7 Ondřej Ezr 2019-09-09 21:16:32 UTC
This should be fixed by https://github.com/theforeman/foreman/pull/7023 and is caused by same issue as BZ#1724780, therefore marking as duplicate.

*** This bug has been marked as a duplicate of bug 1724780 ***


Note You need to log in before you can comment on or make changes to this bug.