Bug 174214 - Dist ISOs missing some RPMs
Dist ISOs missing some RPMs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 18:01 EST by Chris Adams
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 21:57:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Differences between CD's and FTP site (2.74 KB, text/plain)
2005-11-26 11:59 EST, Charles R. Anderson
no flags Details
fix the logic for kernel packages (1.12 KB, patch)
2005-11-26 18:26 EST, Dennis Gregorovic
no flags Details | Diff
set arch to ppc64 for ppc (367 bytes, patch)
2005-11-26 19:07 EST, Dennis Gregorovic
no flags Details | Diff

  None (edit)
Description Chris Adams 2005-11-25 18:01:28 EST
The distributed ISOs are missing some RPMs.  It looks like they are all kernel
related; here's the list I found (from i386 and x86_64):

i386/os/Fedora/RPMS/GFS-kernel-2.6.14.0-20051108.134753.FC5.10.i686.rpm
i386/os/Fedora/RPMS/GFS-kernel-smp-2.6.14.0-20051108.134753.FC5.10.i686.rpm
i386/os/Fedora/RPMS/cman-kernel-2.6.14.0-20051108.134753.FC5.8.i686.rpm
i386/os/Fedora/RPMS/cman-kernel-smp-2.6.14.0-20051108.134753.FC5.8.i686.rpm
i386/os/Fedora/RPMS/dlm-kernel-2.6.14.0-20051108.134753.FC5.10.i686.rpm
i386/os/Fedora/RPMS/dlm-kernel-smp-2.6.14.0-20051108.134753.FC5.10.i686.rpm
i386/os/Fedora/RPMS/gnbd-kernel-2.6.14.0-20051108.134753.FC5.12.i686.rpm
i386/os/Fedora/RPMS/gnbd-kernel-smp-2.6.14.0-20051108.134753.FC5.12.i686.rpm
i386/os/Fedora/RPMS/kernel-devel-2.6.14-1.1696_FC5.i586.rpm
i386/os/Fedora/RPMS/kernel-devel-2.6.14-1.1696_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-doc-2.6.14-1.1696_FC5.noarch.rpm
i386/os/Fedora/RPMS/kernel-kdump-2.6.14-1.1696_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-kdump-devel-2.6.14-1.1696_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-smp-devel-2.6.14-1.1696_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-xen-guest-2.6.12-1.13_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-xen-guest-devel-2.6.12-1.13_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-xen-hypervisor-2.6.12-1.13_FC5.i686.rpm
i386/os/Fedora/RPMS/kernel-xen-hypervisor-devel-2.6.12-1.13_FC5.i686.rpm
x86_64/os/Fedora/RPMS/GFS-kernel-2.6.14.0-20051108.134753.FC5.10.x86_64.rpm
x86_64/os/Fedora/RPMS/cman-kernel-2.6.14.0-20051108.134753.FC5.8.x86_64.rpm
x86_64/os/Fedora/RPMS/dlm-kernel-2.6.14.0-20051108.134753.FC5.10.x86_64.rpm
x86_64/os/Fedora/RPMS/gnbd-kernel-2.6.14.0-20051108.134753.FC5.12.x86_64.rpm
x86_64/os/Fedora/RPMS/kernel-devel-2.6.14-1.1696_FC5.x86_64.rpm
x86_64/os/Fedora/RPMS/kernel-doc-2.6.14-1.1696_FC5.noarch.rpm
Comment 1 Chris Adams 2005-11-25 20:13:51 EST
I submitted this against anaconda becuase IIRC that's where the tools that build
the distribution ISOs come from.  Or did these get left out maybe due to some
build system problem?  They are on the FTP sites (that's how I found them).
Comment 2 Jeremy Katz 2005-11-25 23:46:32 EST
Although there are some pieces of the puzzle in anaconda, it's overall
controlled by some other whole-distro scripts (... which we've also replaced for
this time around, just to keep things more exciting :-)
Comment 3 Charles R. Anderson 2005-11-26 11:59:14 EST
Created attachment 121508 [details]
Differences between CD's and FTP site

Here are the full differences between the CD's and the
download.fedora.redhat.com FTP site.  I've excluded debug/ and things like
TRANS.TBL and .discinfo*.
Comment 4 Dennis Gregorovic 2005-11-26 18:26:31 EST
Created attachment 121513 [details]
fix the logic for kernel packages

The packages listed with "kernel" in their name do appear to be the result of
some bad logic in anaconda's pkgorder script that was causing them to not get
listed.
Comment 5 Dennis Gregorovic 2005-11-26 19:07:03 EST
Created attachment 121514 [details]
set arch to ppc64 for ppc

When the arch is set to "ppc", the ppc64 packages are not included in the
package sack.  They're only included in the pkgorder output when a
correspoinding ppc is outputted.  In general that works fine, but it breaks
down when there is no corresponding ppc package.  This accounts for these
missing files:

+ppc/os/Fedora/RPMS/ccs-1.0.2-3.ppc64.rpm
+ppc/os/Fedora/RPMS/crash-3.10-13.ppc64.rpm
+ppc/os/Fedora/RPMS/diskdumputils-1.1.9-2.ppc64.rpm
+ppc/os/Fedora/RPMS/magma-1.0.3-3.ppc64.rpm

The patch solves this problem by changing the arch to ppc64.  I've confirmed
that this results in including those four packages.  However, it also changes
the overall order a decent amount.  So, I would suggest testing before applying
the patch.
Comment 6 Dennis Gregorovic 2005-11-30 01:14:28 EST
I've checked in fixes for the rest of files.  There were two issues.  

First, ppc was overflowing on disc 5, causing a few packages to get dropped. 
The fix is to make the overflow much more noticeable so that we do something
about it.  

Second, the etc/ and ppc/ subdirs in the ppc tree just weren't getting linked. 
Fixed.

I'm going to reassign this bug to Chris for the anaconda parts.

Note You need to log in before you can comment on or make changes to this bug.