Bug 174227 - su cannot change to new user's home directory
Summary: su cannot change to new user's home directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 174607 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-26 09:29 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 12:25:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marius Andreiana 2005-11-26 09:29:45 UTC
$ su -
Password:
su: warning: cannot change directory to /root: Permission denied
su: warning: cannot change directory to /root: Permission denied

cd works after this.
It also happens with su from root to regular user.

Comment 1 n0dalus 2005-11-26 17:23:57 UTC
I am also having this problem.
I'm not sure if this is related, but after using `su -` I can't load any
graphical programs (just get "Can't connect to X server 0:0" etc).

Comment 2 Marius Andreiana 2005-11-27 07:09:39 UTC
Yes, same for me. The fix is to run 'xhost +' with the original logged in user.
(it used to work without it on FC4). 
I'm not sure this is a bug or feature. Tim, perhaps you could confirm please?

Comment 3 Tim Waugh 2005-11-27 10:47:02 UTC
No, the fix is 'restorecon -v /root'.  So why is /root getting the wrong
security context?  Reassigning to filesystem.

Comment 4 Bill Nottingham 2005-11-28 19:57:55 UTC
Context isn't set in the package. Moving to anaconda, cc'ing policy people.

Comment 5 Jeremy Katz 2005-12-01 03:21:06 UTC
Dan -- did you track anything down here?

Comment 6 Jeremy Katz 2005-12-01 03:34:46 UTC
*** Bug 174607 has been marked as a duplicate of this bug. ***

Comment 7 Daniel Walsh 2006-01-02 16:50:08 UTC
Fixed in policycoreutils-1.29.2-8


Comment 8 Rahul Sundaram 2006-02-20 12:25:28 UTC

This works for me after the recent updates. Closing as fixed. 


Note You need to log in before you can comment on or make changes to this bug.