Bug 174236 - libXft-devel should require fontconfig-devel
libXft-devel should require fontconfig-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXft (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 175806 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 05:21 EST by Adrian Reber
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 18:58:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Reber 2005-11-26 05:21:55 EST
$ rpm -qp libXft-devel-2.1.8-2.i386.rpm  -R
libXft = 2.1.8-2
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

$ cat /usr/lib/pkgconfig/xft.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include
freetypelibs=-lfreetype -lz  
freetypecflags=-I/usr/include/freetype2  
xrenderlibs=-lXrender -lX11 -ldl  
xrendercflags= 

Name: Xft
Description: X FreeType library
Version: 2.1.8
Requires: fontconfig
Libs: -L${libdir} -lXft -lX11 ${freetypelibs} ${xrenderlibs}
Cflags: -I${includedir} ${freetypecflags} ${xrendercflags}

The pkg-config files uses fontconfig and therefore fontconfig-devel should be
required by libXft-devel.
Comment 1 Mike A. Harris 2005-12-13 18:58:00 EST
All of the pkg-config files are very broken in RC2 and contain very incorrect
data.  This is mostly fixed in RC3:

Requires: xproto, xrender, fontconfig, freetype2
Requires.private: xrender, fontconfig, freetype2
Cflags: -I${includedir}
Libs: -L${libdir} -lXft


The Cflags/Libs lines of pkgconfig .pc files should only contain the flags
for the specific library itself, not for all libraries that the library
links to.  This should be resolved in libXft-2.1.8.1
Comment 2 Mike A. Harris 2005-12-15 04:24:42 EST
*** Bug 175806 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.