Bug 174277 - Gnucash fails to start: "Gdk-ERROR **: BadMatch (invalid parameter attributes)"
Gnucash fails to start: "Gdk-ERROR **: BadMatch (invalid parameter attributes)"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 193495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 00:45 EST by Jonathan Gardner
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 14:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Gardner 2005-11-27 00:45:02 EST
Description of problem:
On a fresh install of FC4, I ran "yum -y install gnucash". It seemed to install
without any trouble. However, when I go to run gnucash, it fails with an error:

$ gnucash
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 324 error_code 8 request_code 146 minor_code 3


Version-Release number of selected component (if applicable):
gnucash-1.8.11-3

How reproducible:
Always

Steps to Reproduce:
1. run gnucash from terminal
  
Actual results:
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 324 error_code 8 request_code 146 minor_code 3


Expected results:
gnucash should start.
Comment 1 Jonathan Gardner 2005-12-13 12:13:38 EST
I noticed that it works if I am running GNOME, but produces the error above in KDE.
Comment 2 Bill Nottingham 2006-01-09 13:43:13 EST
I'm assuming this persists with 1.8.12 from the updates dir?
Comment 3 Jonathan Gardner 2006-01-28 13:18:44 EST
Yes. I just upgraded to 1.8.12 and I see the same error.
Comment 4 Bill Nottingham 2006-05-30 15:11:08 EDT
*** Bug 193495 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2006-08-07 14:10:59 EDT
This works for me with 2.0.1 in rawhide; it presumably should work with the
updates-testing gnucash as well.
Comment 6 james 2006-08-10 01:31:31 EDT
Still, now a dependency issue:

$ gnucash
gnucash-bin: error while loading shared libraries: libguile.so.17: cannot open
shared object file: No such file or directory

$ rpm -qf /usr/lib/libguile.so.12
guile-1.6.7-6


Revise the guile package?  or the gnucash package?
Comment 7 Bill Nottingham 2006-08-10 09:10:51 EDT
Eep, I didn't mean to imply that the FC-5 updates-testing gnucash would work on
FC4; you'll probably need to rebuild the SRPM.

Note You need to log in before you can comment on or make changes to this bug.