Bug 174322 - X stops receiving mouse clicks
Summary: X stops receiving mouse clicks
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-27 21:51 UTC by Glen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: fc5 test2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 04:28:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen 2005-11-27 21:51:22 UTC
Description of problem:
After a few minutes of using Gnome, it stops responding sort of.  I can still
move my mouse point around, but clicking anywhere has absolutely no effect.  The
only thing I can do at that point is hit ctrl-alt-backspace.  I also let it sit
there for a good long time to see if things would return to normal, but that
doesn't help.

Version-Release number of selected component (if applicable):
nautilus-2.12.1-6

How reproducible:
Every time

Steps to Reproduce:
1. Log into Gnome and use it for a while
  
Actual results:
Gnome freezes

Expected results:
Gnome not freezing.

Comment 1 Alexander Larsson 2005-11-28 09:10:59 UTC
You filed this against nautilus, but write that "gnome" hangs. Exactly which
part of the desktop are frozen? Nautilus, panel, apps? Does the keyboard work?
Can you ctrl-alt-f1 switch to a VT? Can you ssh into the box over the network?

It seems to me that what you are describing is X hanging. (The mouse movement is
handled by an interrupt and can sometimes work even if most of X is crashed.)

Comment 2 Glen 2005-11-28 13:24:10 UTC
(In reply to comment #1)
> You filed this against nautilus, but write that "gnome" hangs. Exactly which
> part of the desktop are frozen? Nautilus, panel, apps? Does the keyboard work?
> Can you ctrl-alt-f1 switch to a VT? Can you ssh into the box over the network?

Yeah, sorry, I wasn't exactly sure what component is causing my problems so I
picked nautilus.  Well, that and this doesn't happen with KDE, so it seems to be
a Gnome problem.

Anyway, I just started a gnome session and fired up xchat.  I just had to wait a
short why and once again, everything is frozen as far as the mouse goes.  I
can't do anything with my xchat window.  I can't click on the Gnome panel.  I
can't click on the desktop.  Mouse clicks just do not work.  The keyboard does
work though.  I can still type in my xchat window, I can switch to a console, or
to a different X session, etc.  I can't however ssh into the machine.  I don't
run sshd.  =)

Comment 3 Alexander Larsson 2005-11-29 08:39:29 UTC
Very strange. Either something is going wrong with the xserver mouse driver, or
something is doing a mouse grab of some sort. I have no idea what is causing
this, and I don't see it on my box.

I'm reassigning this to X. Maybe they know what could be causing this.

Comment 4 Mike A. Harris 2006-01-31 18:42:49 UTC
Sounds like it could be:

1) kernel problem
2) X server or driver problem
3) something else

There isn't really enough information in the report to fully diagnose or
speculate very accurately though.  Please try to narrow the problem down,
and provide an update to the report.  It might be useful to install the
debuginfo packages for the X server and/or other components, and try
stracing various things.

Since this report was filed however, there have been quite a number of updates
in Fedora development.  Please update to the latest builds of everything,
and update the report.  If the problem still exists, please attach your
X server config file and log file as individual uncompressed file attachments.

TIA


Comment 5 Mike A. Harris 2006-02-02 09:15:21 UTC
Bug #175274 and this one, might be the same issue.  I'm going to reassign
this to the mouse driver for now, while we diagnose.  If it appears to be
something else, we can reassign it again later.

Comment 6 Glen 2006-02-03 04:28:37 UTC
I've been running fc5 test 2 for a few days now and this problem seems to be
gone now.


Note You need to log in before you can comment on or make changes to this bug.