Bug 174349 - Missing area fill selection drop-down from Draw toolbar
Missing area fill selection drop-down from Draw toolbar
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 06:47 EST by Andrew S. Townley
Modified: 2013-04-02 00:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 07:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew S. Townley 2005-11-28 06:47:54 EST
Description of problem:

The version of OpenOffice.org which comes with FC4 is missing the drop-down
control next to the area fill button which allows you to change the
type/color/etc. of an area fill without going through the secondary dialog. 
this is a change from both the previous 1.1.x version and the 2.0 version
available from the OpenOffice.org site.

Version-Release number of selected component (if applicable):

1:2.0.0-3.2.1


How reproducible:

Visible if you look at the toolbar.

Steps to Reproduce:
1. Launch OO Draw
2. Look at the 2nd-level toolbar
3. Notice that there is only the type of fill for the Area Style/Filling control
and there is no way to add this from the toolbar options.
  
Actual results:

You must go through the dialog to change the fill value for the selected style
(for example, to change the color of a fill, you can't use the toolbar anymore).

Expected results:

You should be able to do this from the toolbar like the other versions of
OpenOffice currently available.

Additional info:

I use draw quite extensively, but have only recently upgraded to FC4.  I ended
up uninstalling the FC4 version and downloading the official release because I
use that control hundreds of times a day.  However, if I attempt to update the
system with yum, it whacks the entries for the official version and I have to
uninstall the FC version to get the control back.  Maybe this is some
configuration setting that I'm missing or stuck in an rc file somewhere, but I
can't find it (after much searching).
Comment 1 Caolan McNamara 2005-11-28 07:39:28 EST
Red Hat reviews and scrubs its code for intellectual property issues. Our
approach has always been conservative, i.e., if there is any question, resolve
the issue or remove the code.  Red Hat recently implemented a number of changes
in its  distribution of OpenOffice to address such issues. These changes should
not be construed as implying any immediate intellectual property problem;
rather, they have been implemented to assure that no such immeidate problems
arise. While implementing these changes in our own distribution of OpenOffice,
we have also made them available to the OpenOffice project.
Comment 2 Andrew S. Townley 2005-11-28 08:30:06 EST
(In reply to comment #1)
> Red Hat reviews and scrubs its code for intellectual property issues. Our
> approach has always been conservative, i.e., if there is any question, resolve
> the issue or remove the code.  Red Hat recently implemented a number of changes
> in its  distribution of OpenOffice to address such issues. These changes should
> not be construed as implying any immediate intellectual property problem;
> rather, they have been implemented to assure that no such immeidate problems
> arise. While implementing these changes in our own distribution of OpenOffice,
> we have also made them available to the OpenOffice project.

I don't really see how this serious affect on usability can relate to IPR
issues, but if the code which actually puts the color selector in the toolbar is
the issue, I would politely suggest that you write new code rather than remove
the functionality.  Personally, I can't see from an IPR point of view how the
drop-down for line color (which is still there) is different to the drop-down
control for selecting a fill.  If you don't believe me that this is a serious
usability issue, please try to actually create a large number of objects using
draw with different fills like colors and gradients without the control in the
toolbar and see how the user experience is dramatically changed between the two
versions.

Obviously, I can't insist that this be fixed, however by removing this
functionality, you are doing a great disservice to your customers and making the
product more difficult to use to perform simple, often repetitive tasks. 
Personally, I hope that no-one in OpenOffice accepts this particular change. 
I'm not trying to get RedHat sued, however I am trying to end up with a usable
product.

Note You need to log in before you can comment on or make changes to this bug.