Bug 174363 - RHEL3: rcp outputs negative file size when over 2GB
RHEL3: rcp outputs negative file size when over 2GB
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rsh (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks: 178252 187539
  Show dependency treegraph
 
Reported: 2005-11-28 10:11 EST by Karel Zak
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0231
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 15:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2005-11-28 10:11:24 EST
+++ This bug was initially created as a clone of Bug #174045 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98;
Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b)
Gecko/20050217

Description of problem:
Rcp generates a negative number as the file size when size is over 2GB.


Version-Release number of selected component (if applicable):
rsh-0.17-29

How reproducible:
Always

Steps to Reproduce:
1.rcp file_over_2GB_in_size remotehost
2.
3.
  

Actual Results:  depends on client, but generally causes big problem because
client gets negative file size

Expected Results:  rcp should proceed normally


Additional info:

POlease don't tell me to use scp - this is a bug about rcp.

-- Additional comment from jw203198@hotmail.com on 2005-11-23 19:33 EST --
Created an attachment (id=121428)
Changes faulty %lld into a %llu, and enables largefile support


-- Additional comment from kzak@redhat.com on 2005-11-24 04:54 EST --
Thanks. Fixed in devel (FC5) branche. I'm going to fix it in FC4 next week.

-- Additional comment from kzak@redhat.com on 2005-11-28 10:04 EST --
FC4 version has been fixed. Note -- this report is also valid for RHEL3|4.
Comment 1 Kenneth Topp 2006-01-13 12:40:26 EST
is it also valid for krb5-workstation's rcp??
Comment 5 Red Hat Bugzilla 2006-03-29 15:55:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0231.html

Note You need to log in before you can comment on or make changes to this bug.