Bug 174374 - Can't retrieve reliable values on 64 bits computer's mib with a 32 bits snmp client
Can't retrieve reliable values on 64 bits computer's mib with a 32 bits snmp ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
: 174455 174457 174458 174459 174465 174466 174482 174501 174502 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 12:02 EST by saveline
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:50:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description saveline 2005-11-28 12:02:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
When I try to retrieve some values on my 64 bits box such as ifInOctets with a 32 bits snmp client, I get wrong values. But when I try to get it with another box like a 64 bits snmp client it seems ok.


Version-Release number of selected component (if applicable):
net-snmp-5.0.9

How reproducible:
Always

Steps to Reproduce:
1. snmpwalk -v 2c -c xxxxx xxxx .1.3.6.1.2.1.2.2.1
2.
3.
  

Actual Results:  IF-MIB::ifInOctets.1 = Counter32: 55192
IF-MIB::ifInOctets.2 = Counter32: 55192

Interface 1 is for lo and interface 2 is for eth0


Expected Results:  The ifInOctets.2 and the ifInOctets.1 should be different. And ifInOctets.2 should increase at each query.

Additional info:

As I said, this error appears when I try to query a 64 bits computer's mib with a 32 bits computer's snmp client.
On my 64 box I got net-snmp-5.0.9 and on my 32 bits snmp client I got the same version.
I got the same problem with 64 bits computers under RHEL 4 with net-snmp-5.1.2 .
Comment 1 saveline 2005-11-28 12:13:56 EST
In addition, my bug references this previous bug 171996. 
I tried to patch my net-snmp-5.0.9 with patch provides in bug 171996 but it
wasn't a success.
Comment 2 Radek Vokal 2005-11-29 05:28:34 EST
*** Bug 174459 has been marked as a duplicate of this bug. ***
Comment 3 Radek Vokal 2005-11-29 05:28:55 EST
*** Bug 174458 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vokal 2005-11-29 05:30:21 EST
*** Bug 174457 has been marked as a duplicate of this bug. ***
Comment 5 Radek Vokal 2005-11-29 05:30:42 EST
*** Bug 174455 has been marked as a duplicate of this bug. ***
Comment 6 Radek Vokal 2005-11-29 07:25:11 EST
*** Bug 174465 has been marked as a duplicate of this bug. ***
Comment 7 Radek Vokal 2005-11-29 07:25:51 EST
*** Bug 174466 has been marked as a duplicate of this bug. ***
Comment 8 Radek Vokal 2005-11-29 07:26:38 EST
Please, stop opening new bugs for this issue. Thanks
Comment 9 Radek Vokal 2005-11-30 02:45:11 EST
*** Bug 174482 has been marked as a duplicate of this bug. ***
Comment 10 Radek Vokal 2005-11-30 03:03:50 EST
*** Bug 174501 has been marked as a duplicate of this bug. ***
Comment 11 Radek Vokal 2005-11-30 03:06:10 EST
*** Bug 174502 has been marked as a duplicate of this bug. ***
Comment 12 RHEL Product and Program Management 2007-10-19 14:50:32 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.