Bug 174380 - build root path in loadables/Makefile and loadables/perl/Makefile
build root path in loadables/Makefile and loadables/perl/Makefile
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 12:38 EST by Tim Waugh
Modified: 2008-01-11 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-11-28 12:38:27 EST
Description of problem:
Some Makefiles in the doc directory have build root path contamination:

/usr/share/doc/bash-2.05b/loadables/Makefile
/usr/share/doc/bash-2.05b/loadables/perl/Makefile

Version-Release number of selected component (if applicable):
bash-3.0-37
Comment 1 Kevin Fenzi 2007-03-23 23:51:33 EDT
Sadly, I can confirm that this still seems to be the case in current devel. 
(At least builddir is set to the build root in mock)

Is there any reason to really ship those Makefiles? Perhaps they should just be
removed?
Comment 2 Tomas Janousek 2007-10-30 09:43:13 EDT
If you edit the Makefile, put a path to bash sources there, it manages to
compile a few .c files. I'm not sure whether we should ship the loadables
examples at all.

Debian ships it in a separate package called bash-builtins. They claim the
included Makefile is fixed to work (the buildroot leaked into it too, though),
but I wasn't able to build it (didn't and won't try to su - -c "cd
/usr/share/doc/bash-builtins/examples/loadables/; make", though).

So... I'll probably remove those. Ideas/objections?
Comment 3 Tim Waugh 2007-10-30 09:52:57 EDT
No.
Comment 4 Fedora Update System 2007-11-28 20:32:47 EST
bash-3.2-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash'
Comment 5 Fedora Update System 2007-11-28 20:37:07 EST
bash-3.2-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash'
Comment 6 Fedora Update System 2008-01-11 17:04:33 EST
bash-3.2-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-01-11 17:04:56 EST
bash-3.2-19.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.