Bug 174421 - system-config-display crashes without allowing me to configure video card
system-config-display crashes without allowing me to configure video card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 16:41 EST by Partha Bagchi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 18:56:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Partha Bagchi 2005-11-28 16:41:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
system-config-display
/usr/share/system-config-display/xconf.py:32: DeprecationWarning: rhpl.monitor is deprecated; import rhpxl.monitor instead.
  import rhpl.monitor
/usr/share/system-config-display/xconf.py:33: DeprecationWarning: rhpl.videocard is deprecated; import rhpxl.videocard instead.
  import rhpl.videocard
/usr/share/system-config-display/xconf.py:35: DeprecationWarning: rhpl.mouse is deprecated; import rhpxl.mouse instead.
  import rhpl.mouse
/usr/share/system-config-display/xconf.py:37: DeprecationWarning: rhpl.xhwstate is deprecated; import rhpxl.xhwstate instead.
  from rhpl.xhwstate import *
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 345, in configure_videocard
    self.state)
  File "/usr/share/system-config-display/videocardDialog.py", line 63, in __init__
    selection.select_iter(videocard_store.get_iter_first())
TypeError: iter should be a GtkTreeIter


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start system-config-display
2. Configure video card
3. 
  

Actual Results:  Nothing happens (see error above)

Expected Results:  Should allow me to configure video card?

Additional info:

Running FC5T1, on a compaq Presario X1000 laptop (see my home page www.partha.com)
ATI Radeon Mobility 9200 graphics card.

BTW whatever happened to glxgear? I am not sure how to test the FPS settings anymore.
Comment 1 Rahul Sundaram 2006-02-20 06:25:49 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Martin Stransky 2006-03-03 04:34:50 EST
Could you check the latest version in test3 or rawhide?
Comment 3 Partha Bagchi 2006-03-03 18:40:54 EST
Seems fine now. Thanks!
Comment 4 Rahul Sundaram 2006-03-03 18:56:15 EST
Closing as per last comment

Note You need to log in before you can comment on or make changes to this bug.