This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 174424 - yum update fails in fresh "everything" install
yum update fails in fresh "everything" install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 17:04 EST by Henri Ala-Peijari
Modified: 2014-01-21 17:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Ala-Peijari 2005-11-28 17:04:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
After installing Fedora Core 4 it runs ok, but running yum update fails as follows...
..
..
..
---> Downloading header for squirrelmail to pack into transaction set.
squirrelmail-1.4.6-0.cvs2 100% |=========================| 163 kB    00:00
---> Package squirrelmail.noarch 0:1.4.6-0.cvs20050812.1.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
filelists.xml.gz          100% |=========================| 2.5 MB    00:07
updates-re: ################################################## 1016/1016
Added 1016 new packages, deleted 0 old in 44.29 seconds
filelists.xml.gz          100% |=========================| 2.1 MB    00:05
extras    : ################################################## 2481/2481
Added 2481 new packages, deleted 0 old in 34.03 seconds
filelists.xml.gz          100% |=========================| 2.0 MB    00:02
base      : ################################################## 2772/2772
Added 2772 new packages, deleted 0 old in 37.34 seconds
--> Processing Dependency: eclipse-rcp = 1:3.1.1-1jpp_1fc.FC4.4 for package: eclipse-platform
--> Processing Dependency: lucene for package: eclipse-platform
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: lucene-demo for package: eclipse-platform
--> Processing Dependency: dhcdbd for package: NetworkManager
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for dhcdbd to pack into transaction set.
dhcdbd-1.9-1.FC4.i386.rpm 100% |=========================| 5.2 kB    00:00
---> Package dhcdbd.i386 0:1.9-1.FC4 set to be updated
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.14-1.1637_FC4. 100% |=========================| 192 kB    00:01
---> Package kernel.i686 0:2.6.14-1.1637_FC4 set to be installed
---> Downloading header for eclipse-rcp to pack into transaction set.
eclipse-rcp-3.1.1-1jpp_1f 100% |=========================|  15 kB    00:00
---> Package eclipse-rcp.i386 1:3.1.1-1jpp_1fc.FC4.4 set to be updated
---> Downloading header for lucene-demo to pack into transaction set.
lucene-demo-1.4.3-1jpp_3f 100% |=========================| 3.5 kB    00:00
---> Package lucene-demo.i386 0:1.4.3-1jpp_3fc set to be updated
---> Downloading header for lucene to pack into transaction set.
lucene-1.4.3-1jpp_3fc.i38 100% |=========================| 4.4 kB    00:00
---> Package lucene.i386 0:1.4.3-1jpp_3fc set to be updated
--> Running transaction check
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.14-1.1637_FC4 set to be installed
--> Running transaction check
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.14-1.1637_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.14-1.1637_FC4 set to be installed
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package cman-kernel needs /lib/modules/2.6.14-1.1637_FC4, this is not available.
Error: Package GFS-kernel needs /lib/modules/2.6.14-1.1637_FC4, this is not available.
Error: Package gnbd-kernel needs /lib/modules/2.6.14-1.1637_FC4, this is not available.
Error: Package dlm-kernel needs /lib/modules/2.6.14-1.1637_FC4, this is not available. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC4 with "everything"
2.run yum update
3.update fails
  

Actual Results:  Yum is unable to update system. It is possible to get arround by using the system behind the "Exclamation Mark" and leaving out the offending kernel components.


Expected Results:  An uptodate system.

Additional info:

This happened on two installs on separate machines, so I'm confident that this affects all fresh installs with everything installed.
Comment 1 Robert 2005-11-30 23:13:09 EST
i have the same error on my box as well.  i'm not sure as to what the platform
the original person is using, but i am on an i686 (AMD athlon xp) architecture.
 i'm not sure if this makes a differance, as i did an "everything" install as well.
Comment 2 Jason Tibbitts 2006-02-01 22:39:17 EST
It looks like this was fixed with the December 13/14 updates of the kernel and
the cman/GFS/gnbd/dlm modules, but then broke again with the January 6 kernel
update.  There are updated modules in updates-testing since Jan 30 for the
currently released update kernel (2.6.14-1.1656) but then updates-testing also
has kernel 2.6.15-1.1824.  There's just no winning.

I'm just trying to build updated install media.  I think the only solution in
any case is to uninstall or remove the cman/GFS/gnbd/dlm packages.  Eventually
I'm sure everything will settle down.
Comment 3 Jeremy Katz 2006-04-19 16:27:35 EDT
Should be better now

Note You need to log in before you can comment on or make changes to this bug.