Bug 174425 - Missing driver for Cirrus graphics ?
Missing driver for Cirrus graphics ?
Status: CLOSED DUPLICATE of bug 176225
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-cirrus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 17:33 EST by Stuart Ellis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 06:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1.0.0.2-1 spec file patch (2.66 KB, patch)
2005-12-02 17:50 EST, bkyoung
no flags Details | Diff
Temporary Makefile patch (1.83 KB, patch)
2005-12-02 17:51 EST, bkyoung
no flags Details | Diff

  None (edit)
Description Stuart Ellis 2005-11-28 17:33:14 EST
Description of problem:

Graphical install fails to start on QEMU 0.7.1, due to X server being unable to
load a cirrus_alpine module. QEMU emulates a Cirrus Logic GD 5446 graphics card.

Version-Release number of selected component (if applicable):

FC5t1 CD1

How reproducible:

Steps to Reproduce:
1. Start QEMU
2. Boot guest from CD
3. Accept defaults to start graphical install
  
Actual results:

Install halts with the message:

mini-wm: Fatal IO error 104 (Connection reset by peer) on X server :1.0.

Expected results:

Graphical installation process should start.

Additional info:

X.log message:

(EE) Failed to load module "cirrus_alpine" (module does not exist, 0)
(EE) No devices detected

Fatal server error:
No screens found
Comment 1 Jeremy Katz 2005-11-30 22:26:43 EST
I don't see that in the xorg-x11-drv-cirrus package
Comment 2 Mike A. Harris 2005-12-01 05:11:51 EST
Due to an X.Org oversight, the cirrus_laguna and cirrus_alpine sub-drivers are
missing from the cirrus driver package in modular X currently.  I believe this
is fixed in CVS however, and should be part of the RC3 release in a few days,
which we'll be updating to shortly.

Thanks for the report.
Comment 3 bkyoung 2005-12-02 17:50:06 EST
Created attachment 121786 [details]
1.0.0.2-1 spec file patch
Comment 4 bkyoung 2005-12-02 17:51:16 EST
Created attachment 121787 [details]
Temporary Makefile patch

This should help until FC5-test2
Comment 5 Mike A. Harris 2005-12-21 06:27:50 EST

*** This bug has been marked as a duplicate of 176225 ***

Note You need to log in before you can comment on or make changes to this bug.