Bug 174438 - panic on EHCI using uninitialised spinlock
panic on EHCI using uninitialised spinlock
Status: CLOSED DUPLICATE of bug 174270
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 21:02 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 18:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch from David Brownell (1.60 KB, patch)
2005-11-29 10:48 EST, David Woodhouse
no flags Details | Diff

  None (edit)
Description David Woodhouse 2005-11-28 21:02:57 EST
This backtrace didn't show up on-screen -- not sure if it's our silly setting of
loglevel, or xmon interfering with BUG(). But booting with 'dontpanic' on the
command line lets it boot, and I see the backtrace in dmesg. 

The 1.1709 kernel works; 1.1712 doesn't. 

ehci_hcd 0001:02:0b.2: EHCI Host Controller
BUG: spinlock bad magic on CPU#1, modprobe/724 (Not tainted)
 lock: c00000007f4b12a0, .magic: 00000000, .owner: <none>/-1, .owner_cpu: 0
Call Trace:
[C00000000F35B110] [C00000000002C6A8] .show_stack+0x68/0x1d0 (unreliable)
[C00000000F35B1B0] [C0000000001BA504] .spin_bug+0xd4/0x150
[C00000000F35B260] [C0000000001BA898] ._raw_spin_lock+0xc8/0x1d0
[C00000000F35B300] [C0000000003D7F64] ._spin_lock_irqsave+0x24/0x40
[C00000000F35B390] [D00000000010565C] .ehci_hub_control+0x5c/0xa20 [ehci_hcd]
[C00000000F35B450] [D00000000010609C] .ehci_port_power+0x7c/0xc0 [ehci_hcd]
[C00000000F35B4F0] [D000000000106214] .ehci_pci_reinit+0x134/0x450 [ehci_hcd]
[C00000000F35B5C0] [D0000000001085B4] .ehci_pci_reset+0x114/0x6f0 [ehci_hcd]
[C00000000F35B680] [C0000000001D4DDC] .usb_add_hcd+0x9c/0x8f0
[C00000000F35B750] [C0000000001E1314] .usb_hcd_pci_probe+0x1e4/0x300
[C00000000F35B800] [C0000000001C5CAC] .pci_device_probe+0xfc/0x160
[C00000000F35B8B0] [C000000000297D88] .driver_probe_device+0x98/0x160
[C00000000F35B940] [C00000000029802C] .__driver_attach+0xcc/0xf0
[C00000000F35B9D0] [C000000000296B88] .bus_for_each_dev+0x88/0xe0
[C00000000F35BA80] [C000000000297A08] .driver_attach+0x28/0x40
[C00000000F35BB00] [C000000000297344] .bus_add_driver+0xc4/0x200
[C00000000F35BBB0] [C000000000298564] .driver_register+0x84/0xb0
[C00000000F35BC60] [C0000000001C5664] .__pci_register_driver+0xb4/0x120
[C00000000F35BD10] [D00000000010C904] .ehci_hcd_pci_init+0x34/0x60 [ehci_hcd]
[C00000000F35BD90] [C000000000094684] .sys_init_module+0x1a4/0x4a0
[C00000000F35BE30] [C000000000008778] syscall_exit+0x0/0x40
Bad locking
Comment 1 David Woodhouse 2005-11-29 10:48:58 EST
Created attachment 121589 [details]
Patch from David Brownell

2.6.14-1.1720 is building now with this patch
Comment 2 Dave Jones 2005-11-29 18:05:51 EST

*** This bug has been marked as a duplicate of 174270 ***

Note You need to log in before you can comment on or make changes to this bug.