Bug 174466 - Can't retrieve reliable values on 64 bits computer's mib with a 32 bits snmp client
Can't retrieve reliable values on 64 bits computer's mib with a 32 bits snmp ...
Status: CLOSED DUPLICATE of bug 174374
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-29 07:19 EST by saveline
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 07:25:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description saveline 2005-11-29 07:19:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
When I try to retrieve some values on my 64 bits box such as ifInOctets with a 32 bits snmp client, I get wrong values. But when I try to get it with another box like a 64 bits snmp client it seems ok.


Version-Release number of selected component (if applicable):
net-snmp-5.0.9

How reproducible:
Always

Steps to Reproduce:
1. snmpwalk -v 2c -c xxxxx xxxx .1.3.6.1.2.1.2.2.1
2.
3.
  

Actual Results:  IF-MIB::ifInOctets.1 = Counter32: 55192
IF-MIB::ifInOctets.2 = Counter32: 55192

Interface 1 is for lo and interface 2 is for eth0


Expected Results:  The ifInOctets.2 and the ifInOctets.1 should be different. And ifInOctets.2 should increase at each query.

Additional info:

As I said, this error appears when I try to query a 64 bits computer's mib with a 32 bits computer's snmp client.
On my 64 box I got net-snmp-5.0.9 and on my 32 bits snmp client I got the same version.
I got the same problem with 64 bits computers under RHEL 4 with net-snmp-5.1.2 .
Comment 1 Radek Vokal 2005-11-29 07:25:44 EST

*** This bug has been marked as a duplicate of 174374 ***

Note You need to log in before you can comment on or make changes to this bug.