Bug 174483 - oowriter crashes when saving file
oowriter crashes when saving file
Status: CLOSED DUPLICATE of bug 174461
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-29 10:00 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 10:11:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-29 10:00:05 EST
Description of problem:
oowriter crashes when saving file with <ctrl>S

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.1-0.142.1.2
kernel-2.6.14-1.1719_FC5

How reproducible:
100%

Steps to Reproduce:
1. start oowriter
2. open .odt document
3. type <crtl>S
  
Actual results:
Video Driver is probably i810
OpenOffice.org core rpm version is openoffice.org-core-2.0.1-0.142.1.2
0x578a93c: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e93c
0x578b141: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f141
0xb36420:  + 0x420 (__kernel_sigreturn + 0x0)
0x4db4c75: /usr/lib/openoffice.org2.0/program/libfwe680li.so + 0x33c75
(framework::LockHelper::~LockHelper() + 0x37)
0x4db36af: /usr/lib/openoffice.org2.0/program/libfwe680li.so + 0x326af
0x4dde508: /usr/lib/openoffice.org2.0/program/libfwe680li.so + 0x5d508
(framework::PreventDuplicateInteraction::~PreventDuplicateInteraction() + 0x74)
0x40dcf2: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x20cf2 (cppu::OWeakObject::release() + 0x44)
0x4ddf0f9: /usr/lib/openoffice.org2.0/program/libfwe680li.so + 0x5e0f9
0x5ce1d8e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x99d8e
0x3cddee: /usr/lib/openoffice.org2.0/program/libuno_cppu.so.3 + 0xedee
0x3d66f0: /usr/lib/openoffice.org2.0/program/libuno_cppu.so.3 + 0x176f0
(uno_any_destruct + 0x24)
0x5ce1daf: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x99daf
0x5dcc2ad: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1842ad
0x5b5f4ef: /usr/lib/openoffice.org2.0/program/libsvl680li.so + 0x6f4ef
(SfxItemPool::Remove(SfxPoolItem const&) + 0x85)
0x5b62ceb: /usr/lib/openoffice.org2.0/program/libsvl680li.so + 0x72ceb
(SfxAllItemSet::Put(SfxPoolItem const&, unsigned short) + 0x233)
0x5cf7560: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xaf560
0x5d83240: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x13b240
0x5d849ce: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x13c9ce
0x5df5fcc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1adfcc
0x5df53b9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad3b9
0x5df56cd: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad6cd
0x5df5770: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad770
0x5cf1a2c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa9a2c
0x5e0e6ad: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c66ad
0x5e0e568: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6568
0x5e0e6c2: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c66c2
0x5e0e554: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6554
0x4f4005a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8405a
0x5099ff5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ddff5
0x1089f36: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ef36
0x10b03c3: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x453c3
(SalDisplay::DispatchInternalEvent() + 0xad)
0xb0d40b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1940b
0x40aba6f: /usr/lib/libglib-2.0.so.0 + 0x26a6f
0x40a9810: /usr/lib/libglib-2.0.so.0 + 0x24810 (g_main_context_dispatch + 0x1dc)
0x40ac816: /usr/lib/libglib-2.0.so.0 + 0x27816
0x40acc9e: /usr/lib/libglib-2.0.so.0 + 0x27c9e (g_main_context_iteration + 0x62)
0xb0d03d: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1903d
0x10b1629: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46629
(X11SalInstance::Yield(unsigned char) + 0x29)
0x4f463ce: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a3ce
(Application::Yield() + 0x50)
0x4f4640c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a40c
(Application::Execute() + 0x26)
0x64bbcd5: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25cd5
(desktop::Desktop::Main() + 0x15df)
0x4f4b7fd: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8f7fd
0x4f4b8ad: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8f8ad (SVMain()
+ 0x29)
0x64b3233: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d233 (sal_main
+ 0x57)
0x64b327f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d27f (main + 0x27)
0x1f762f: /lib/libc.so.6 + 0x1562f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4c5

Expected results:
No crashes.  Reliable automatic saves so that work isn't lost!!!

Additional info:
Comment 1 Sammy 2005-11-29 10:09:44 EST
I cannot reproduce this on my x86_64 with everything at today's rawhide level  
except kernel at 2.6.14-1.1637_FC5.  
Comment 2 Caolan McNamara 2005-11-29 10:11:42 EST

*** This bug has been marked as a duplicate of 174461 ***

Note You need to log in before you can comment on or make changes to this bug.