Bug 174506 - test_bit implementation broken on s390
Summary: test_bit implementation broken on s390
Status: CLOSED DUPLICATE of bug 179626
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Glauber
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 170416
TreeView+ depends on / blocked
 
Reported: 2005-11-29 16:29 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 13:48:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testbit.diff (521 bytes, patch)
2005-11-29 16:29 UTC, Bastien Nocera
no flags Details | Diff

Description Bastien Nocera 2005-11-29 16:29:48 UTC
kernel-2.6.9-22.0.1.EL

The __test_bit implementation is broken on s390. The patch is already upstream.
Without it, the LTP mincore test fails.

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=187dfc67b461058bbb84a923a17871ed54e10f30

Comment 1 Bastien Nocera 2005-11-29 16:29:49 UTC
Created attachment 121593 [details]
testbit.diff

Comment 3 Jan Glauber 2006-02-28 13:45:37 UTC
patch was sent to rh-kernel by Eric Paris for U4.

Comment 4 Jan Glauber 2006-02-28 13:48:32 UTC

*** This bug has been marked as a duplicate of 179626 ***


Note You need to log in before you can comment on or make changes to this bug.